#1 25/10/2010 12:58:13

king76
Membre
Lieu : Québec
Inscription : 17/08/2009
Messages : 136
Site Web Mythbox

[Résolu] Il faut que je réinstalle lirc ! Please

Allo,

Avant de débuter, j'ai mythbuntu 10.10, une carte Hauppauge PVR-150 avec la télécommande MCEUSB2, le tout fonctionne plutôt bien depuis 2 ans.

La dernière fois que je suis venu vous solliciter, c'était pour un problème de disque dur qui avait planté, aujourd'hui c'est parce qu'après avoir migré mon Mythbuntu vers 10.10, mon lirc a planté !

Tout a commencé avec un problème de commande qui s'executait deux fois (un déplacement vers le haut et hop je me retrouvais deux éléments au dessus..). Si j'étais venu ici, j'aurais sans doute pu lire ce dernier billet dans le forum http://mythtv-fr.tuxfamily.org/forums/v … hp?id=1489 et ca aurait surement marcher qui sait.

Sauf que le problème s'est compliqué, à force de toucher à tous les fichiers..

Je crois que le module lirc ne se chargeait plus.. j'ai donc mis la variable LOAD_MODULES à FALSE dans mon fichier /etc/lirc/hardware.conf et la télécommande marchait à moitié, pas toutes les touches.

Je me suis donc attaqué à remettre cela a TRUE et tenter de régler le problème en suivant ce tuto : http://www.mythtv.org/wiki/ubuntu_lirc_install

La commande "sudo modprobe lirc_mceusb2" ne marchait pas et après installation de plusieurs paquets ou disons une mise a jour du système pour le bon kernek (c'est ce que j'imagine), ca a fini par se charger.

Mais... on dirait que le module est chargé, mais pas configuré.

La commande "sudo dpkg-reconfigure lirc-modules-source" serait censé m'afficher une fenêtre de configuration, mais non rien...

En allant plus loin dans le tuto, il y a un ensemble de commande telle que :

sudo m-a update,prepare
sudo rm /usr/src/lirc*deb
sudo m-a clean lirc
sudo m-a a-i -f lirc
sudo depmod -a

c'est à partir de la commande "sudo m-a a-i -f lirc" que beaucoup de choss s'activent.. mais qui génère aussi des erreurs.

Au début je vois ceci :

Préparation du remplacement de lirc-modules-source 0.8.7~pre3-0ubuntu1 (en utilisant .../lirc-modules-source_0.8.7~pre3-0ubuntu1_all.deb) ...
Removing all DKMS Modules

puis 

Loading new lirc-0.8.7~pre3 DKMS files...
Building only for 2.6.35-22-generic
Building for architecture i686
Building initial module for 2.6.35-22-generic
Done.

J'ai même été jusqu'a installé une version plus ancienne de lirc via un fichier .deb, mais ce fut pire.

Dans les différentes étapes j'ai cette erreur :

Error! Module version 0.6 for lirc_imon.ko
is not newer than what is already found in kernel 2.6.35-22-generic (0.8).
You may override by specifying --force.

A la fin dans une fenêtre bleue j'ai cette erreur :

La construction du paquet lirc-modules-source a échoué. Que souhaitez-vous faire ? 

Et dans le log ceci :

Build log starting, file:                                                   
 │ /var/cache/modass/lirc-modules-source.buildlog.2.6.35-22-generic.128800410  
 │ 4                                                                           
 │ Date: Mon, 25 Oct 2010 06:55:04 -0400

Quand la fenêtre bleue se ferme, j'ai ce message :

DKMS: install Completed.

Données de 1 paquets mises à jour
unpack 
The source tarball could not be found!
Package lirc-modules-source not installed?
Running "m-a -f get lirc-modules-source" may help.
"/usr/share/modass/packages/default.sh" build KVERS=2.6.35-22-generic KSRC=/usr/src/linux KDREV=2.6.35-22.35 kdist_image
find: `/usr/src/modules/lirc*': No such file or directory

un "uname -r" affiche ceci :

2.6.35-22-generic

Que faire ?

Gros merci !


Pour tout connaître sur ma configuration : http://mythtv-fr.tuxfamily.org/wiki/utilisateur/king76

Hors ligne

#2 25/10/2010 13:41:28

piratebab
Co-fondateur de MythTV-fr
Lieu : Sud Ouest
Inscription : 30/11/2007
Messages : 4 064
Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

J'ai l'impression que tu as mis une belle pagaille dans ton système!
Je te conseille de tout éffacer ce qui concerne lirc (via synaptic en éffaçant les fichiers de config, ou en CLI avec l'option --purge).
L'instal de lirc via les sources ne doit étre tentée que lorsque tout à échoué. Utilise le paquet précompilé fourni par ta distribution.
Concernant les touches "qui rebondissen", j'ai vu un truc hier soir pour une nova-T-500. est ce que c'est la même carte que toi.


Mythuser depuis 2005

Hors ligne

#3 25/10/2010 13:47:30

king76
Membre
Lieu : Québec
Inscription : 17/08/2009
Messages : 136
Site Web Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

Ouais je crois aussi que j'ai mis la pagaille lol..

Je vais dans ce cas la essayer de tout désinstaller et au besoin faire des copies des fichiers de config, bien que je ne change jamais rien dedans en principe. Mais je ne suis pas sur que ca va changer de quoi.

Moi ma carte c'est une Hauppauge PVR-150 ce qui y'a de plus classique pour Mythtv !

Merci


Pour tout connaître sur ma configuration : http://mythtv-fr.tuxfamily.org/wiki/utilisateur/king76

Hors ligne

#4 25/10/2010 14:21:37

gilles74
Administrateur, expert MythTVExpert en configuration du DVB-SAT., développeurMembre de l'équipe de traduction, s'occupe de l'adaptation francophone de accuweather.
Inscription : 20/02/2008
Messages : 3 914
Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

En cherchant un peu tu aurais trouvé la solution à ton premier problème dans les dernières lignes de ce tuto.

Maintenant comme dit Piratebab, il faut faire du ménage et reconstruire (et je suis d'accord avec lui, inutile de compiler sans que ce soit impérativement nécessaire), bonne chance wink

Dernière modification par gilles74 (25/10/2010 14:23:18)

Hors ligne

#5 25/10/2010 14:36:52

king76
Membre
Lieu : Québec
Inscription : 17/08/2009
Messages : 136
Site Web Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

C'est juste con.. qu'après une mise à jour de mon Mythbuntu j'ai encore à jouer dans la configuration. Tous les 6 mois je galère comme pas possible, y'a toujours un truc qui se met à ne plus marcher grrr

Je connais cette page, je vois bien le paragraphe a la fin qui pourrait m'aider, mais ce tutos se font vite vieux quand on a les dernières versions. Comme on peut le voir dans mon message j'ai la dernière version de Lirc (Et c'est pas moi qui l'ai compilé ou quoi que ce soit.. c'était de base avec Mythbuntu..).
je suis pas sur que leur patch servent à de quoi.

En faite.. je me demande si je ne devrais pas réinstaller Mythtbuntu 10.10 en repartant de zéro.. en faisant une copie de ma bdd avant bien sur wink Encore que dans la dernière version que j'ai de Mythtbuntu y'a un outil pour backupé la base de données wink

A+ et merci de vos messages


Pour tout connaître sur ma configuration : http://mythtv-fr.tuxfamily.org/wiki/utilisateur/king76

Hors ligne

#6 25/10/2010 14:37:23

piratebab
Co-fondateur de MythTV-fr
Lieu : Sud Ouest
Inscription : 30/11/2007
Messages : 4 064
Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

Tu as aussi la solution ICI, c'est la même télécommande.


Mythuser depuis 2005

Hors ligne

#7 25/10/2010 14:39:08

king76
Membre
Lieu : Québec
Inscription : 17/08/2009
Messages : 136
Site Web Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

J'avais testé cette solution, c'est même la première que j'avais testé... mais mon module deja a ce moment la ne marchait plus.

On dirait qu'après la mise a jour de Mythbuntu ou ubuntu tout simplement, le module s'est mis a déconné, problème avec la version du kernel qui aurait été updaté ? qui sait.. mystère...


Pour tout connaître sur ma configuration : http://mythtv-fr.tuxfamily.org/wiki/utilisateur/king76

Hors ligne

#8 25/10/2010 15:27:37

Ookaze
Expert MythTVMembre de l'équipe de traduction et traducteur de la documentation.
Inscription : 15/01/2008
Messages : 884
Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

Tu seras forcément en misère de toutes façons, parce qu'en plus d'avoir bidouillé, tu l'as fait au pire moment possible (ce n'est pas une critique, juste un constat).
En effet, les modules noyau LIRC ont été inclus dans le noyau Linux à partir du 2.6.35, or c'est pris en compte dans l'installation par ta distribution évidemment, et elle vérifie quelle version installer entre la version noyau du module ou la version LIRC.
Bref, comme tu ne comprends pas tout ce que tu fais et que tu es sur une distribution, il sera sans doute plus rapide de repartir à neuf, mais attention quand même, car si tu ne sauvegardes que ta base de données, tu risques de perdre d'autres fichiers de configuration importants. Comme ta définition des touches de télécommande par exemple, mais à ce que j'ai compris c'est déjà trop tard pour ça...

Hors ligne

#9 25/10/2010 15:48:54

natrio
Membre
Inscription : 12/11/2008
Messages : 90
Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

Moi aussi lirc me rend dingue. après la résolution de se poste (http://mythtv-fr.tuxfamily.org/forums/v … hp?id=1489) je pensai pouvoir me débrouiller un minimum avec lirc.

Pas de bol. Comme toi, king76, je fais la mise a jour vers Mythbuntu 10.10 et lirc re-déconne... Je pense que cette fois le problème ne se situe pas au niveau du fichier ~/.lircrc (plus précisément, ~/.lirc/mythtv sous Mythbuntu).

Comme toi après le passage sous Mythbuntu tous les bouton ne semble pas tous reconnus. Up et Down fonctionne sous mythtv, par contre le bouton multimon (pour toi cela correspond au gros bouton vert central de ta télécommande) ne fonctionne pas alors qu'il est correctement renseigné dans le fichier.

Lorsque je teste avec irw, les boutons up et down, aucun code ne m'est renvoyer mais ils fonctionnent sous mythtv. Pour le bouton multimon pas de code et ne fonctionne pas sous mythtv... Si je tente refaire un fichier avec irrecorde aucun boutons ne me renvois de code ==> échec de cération du fichier.

Par contre je n'est fait aucune modifications du fichier hardware.conf et des modules.

Avais tu le même problème ?

Hors ligne

#10 25/10/2010 16:39:52

dalgwen
Expert MythTV
Inscription : 16/12/2007
Messages : 617
Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

natrio a écrit :

Comme toi après le passage sous Mythbuntu tous les bouton ne semble pas tous reconnus. Up et Down fonctionne sous mythtv, par contre le bouton multimon (pour toi cela correspond au gros bouton vert central de ta télécommande) ne fonctionne pas alors qu'il est correctement renseigné dans le fichier.

Lorsque je teste avec irw, les boutons up et down, aucun code ne m'est renvoyer mais ils fonctionnent sous mythtv. Pour le bouton multimon pas de code et ne fonctionne pas sous mythtv... Si je tente refaire un fichier avec irrecorde aucun boutons ne me renvois de code ==> échec de cération du fichier.

Par contre je n'est fait aucune modifications du fichier hardware.conf et des modules.

Avais tu le même problème ?

Visiblement il y a un module noyau, complètement extérieur à LIRC, qui est chargé et qui convertit quelques touches de la télécommande directement en frappes claviers. Ça arrive parfois sur certaines télécommandes, particulièrement sur les touches fléchées.
C'est pour ça que IRW ne voit rien. Là, dans votre cas, LIRC ne marche pas du tout et est complètement "sauté". MythTV, de son point de vue, réagit à des touches claviers standard.


Disclaimer : J'ai migré sur tvheadend mais je passe encore ici de temps en temps (bouuhhh le traître)

Hors ligne

#11 25/10/2010 16:53:43

king76
Membre
Lieu : Québec
Inscription : 17/08/2009
Messages : 136
Site Web Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

Allo,

Ookaze tu me fais rire quand tu fais des allusions à mes conneries et "Bref, comme tu ne comprends pas tout ce que tu fais" wink Ca me fait rire parce que c'est la vérité lol

Natrio,

Je crois que tu as le même bleme que moi.. a vrai dire avec tous les bogues que j'ai cité plus haut.. je me rend compte que la télécomande marche quand meme, mais juste les touches droite et gauche genre... pas la touche du centre.

Mon IRW me renvoit rien non plus..

Mon module se charge bien, mais il est comme bogué..

De ce que je comprend, après la mise a jour en 10.10, Lirc a changé de quoi.. qui fait que ca marche a moitié... et qu'on est pogné avec (pour parlé en bon québécois lol)

A+


Pour tout connaître sur ma configuration : http://mythtv-fr.tuxfamily.org/wiki/utilisateur/king76

Hors ligne

#12 25/10/2010 17:16:24

natrio
Membre
Inscription : 12/11/2008
Messages : 90
Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

Visiblement il y a un module noyau, complètement extérieur à LIRC, qui est chargé et qui convertit quelques touches de la télécommande directement en frappes claviers.

Comment pourrait-on l'identifier ? J'ai remarqué une chose. Je ne sait pas trop comment cela fonctionne au niveau de lirc/Linux mais il semble que lorsque lirc se lance il crée (arrêtez moi si je me trompe) un socket. Les application se connecte alors a ce socket a cette adresse /dev/lirc ou /dev/lirc0. Chez moi j'ai remarqué qu'il ne créer se socket à cette adresse : /dev/lircd. Je ne sait pas s'il y a un lien...

Je ferai quelques investigations supplémentaires se soir.

@ king76,

Je parle pas le québécois couramment, mais on vas le révolver se problème ! big_smile
Si on est deux a avoir le même problème on vas le résoudre 2x plus vite hmmtongue Non ?

Hors ligne

#13 25/10/2010 18:01:52

king76
Membre
Lieu : Québec
Inscription : 17/08/2009
Messages : 136
Site Web Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

Ouais on a le même probleme.. sauf que moi ca fait x jours que je l'ai et que personne ne peux plus utiliser la tv a la maison.. suis "tanné" lol

Avec le décalage horaire.. tu vas pouvoir y bosser dessus pendant que moi je serais au travail et vice versa lol

Sauf que je ne vais pas avoir le temps de faire tout ce que l'on m'a préconisé ici avant deux jours au mois.. trop oqp !

A+


Pour tout connaître sur ma configuration : http://mythtv-fr.tuxfamily.org/wiki/utilisateur/king76

Hors ligne

#14 25/10/2010 18:49:58

dalgwen
Expert MythTV
Inscription : 16/12/2007
Messages : 617
Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

natrio a écrit :

Chez moi j'ai remarqué qu'il ne créer se socket à cette adresse : /dev/lircd.

/dev/lircd c'est le chemin standard, au moins sur les debian ou ses dérivées.
De même le frontend MythTV cherche par défaut à se connecter à cette socket (au moins sur Debian et dérivées).
Donc si une socket est créée à cet emplacement, c'est plutôt une bonne nouvelle.
Je me suis fait un pense bête sur LIRC pour me souvenir de comment il marche (juste les grands principes, pas le détail de l'implémentation). Si ça t'intéresse il est ici : http://mmed.roulleau.net/?p=7


Disclaimer : J'ai migré sur tvheadend mais je passe encore ici de temps en temps (bouuhhh le traître)

Hors ligne

#15 25/10/2010 19:52:05

natrio
Membre
Inscription : 12/11/2008
Messages : 90
Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

Ok,

J'ai regardé ton article. Intéressant. Cela m'a permis de clarifier deux ou trois petites choses.
Et de me pauser des question wink.

Comment repère tu /dev/ttyUSB0 ? Comment l'identifier ?

Je vais essayer de retracer tu se qui passe lors du démarrage de lirc afin d'identifier s'il y a des anomalies.

Lol, j'aime le décalage horaire on peux bosser non-stop !! roll
Mais pour moi c'est pareil, mes études sont terminé et je déménage en fin de semaine. Je risque de ne plus êtres présent avant la semaine prochaine.

Hors ligne

#16 25/10/2010 21:25:35

piratebab
Co-fondateur de MythTV-fr
Lieu : Sud Ouest
Inscription : 30/11/2007
Messages : 4 064
Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

Votre télécommande utilises t elle le module evdev intégré au noyau ? En d'autres termes, est elle vu comme un event ?
Si c'est le cas, inspirez vous de ce tuto

Dernière modification par piratebab (26/10/2010 07:59:25)


Mythuser depuis 2005

Hors ligne

#17 26/10/2010 03:03:57

king76
Membre
Lieu : Québec
Inscription : 17/08/2009
Messages : 136
Site Web Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

Effectivement je confirme, ma télécommande n'envoit pas de signal à IRW.. mais elle fonctionne comme si j'étais au clavier, sur le bureau ca se déplace pour passer d'un icone a l'autre wink

J'ai viré tous les fichiers dans .lirc et regénéré le tout, mais ca n'a rien changé.

Demain je vais désinstaller tout pour voir ce que ca pourrait donner..


Pour tout connaître sur ma configuration : http://mythtv-fr.tuxfamily.org/wiki/utilisateur/king76

Hors ligne

#18 26/10/2010 08:35:26

gilles74
Administrateur, expert MythTVExpert en configuration du DVB-SAT., développeurMembre de l'équipe de traduction, s'occupe de l'adaptation francophone de accuweather.
Inscription : 20/02/2008
Messages : 3 914
Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

Inutile de faire des gesticulations dans tous les sens (installation/de-installation) tant que vous n'avez pas identifié comment est monté votre récepteur IR.

Si le noyau a décidé de monter un autre module que celui installé précédamment, c'est certain que ça ne fonctionnera jamais.

Un coup de "lsmod" et de "cat /proc/bus/input/devices" devrait nous en apprendre plus et savoir si Piratebab a raison.

Hors ligne

#19 26/10/2010 12:49:11

king76
Membre
Lieu : Québec
Inscription : 17/08/2009
Messages : 136
Site Web Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

Salut,

C'est sûr que si vous nous filez les commandes au compte goute, on va passer pour des idiots lol

Merci pour les commandes... voici le résultat de lsmod :

Module                  Size  Used by
nfsd                  241120  11 
lockd                  65605  1 nfsd
nfs_acl                 2257  1 nfsd
auth_rpcgss            33937  1 nfsd
sunrpc                193178  12 nfsd,lockd,nfs_acl,auth_rpcgss
exportfs                3449  1 nfsd
nvidia               9329739  38 
tuner_simple           13641  1 
tuner_types            14575  1 tuner_simple
wm8775                  2941  1 
snd_via82xx            20140  3 
tuner                  20578  1 
gameport                9327  1 snd_via82xx
cx25840                28795  1 
snd_usb_audio          86704  2 
snd_ac97_codec         99227  1 snd_via82xx
ac97_bus                1014  1 snd_ac97_codec
snd_pcm                71475  3 snd_via82xx,snd_ac97_codec,snd_usb_audio
snd_mpu401_uart         5661  1 snd_via82xx
snd_page_alloc          7120  2 snd_via82xx,snd_pcm
snd_hwdep               5040  1 snd_usb_audio
snd_usbmidi_lib        17413  1 snd_usb_audio
snd_seq_midi            4588  0 
snd_rawmidi            17783  3 snd_mpu401_uart,snd_usbmidi_lib,snd_seq_midi
ir_sony_decoder         1889  0 
snd_seq_midi_event      6047  1 snd_seq_midi
ir_jvc_decoder          1950  0 
snd_seq                47174  2 snd_seq_midi,snd_seq_midi_event
lirc_mceusb            13068  0 
ir_rc6_decoder          2334  0 
lirc_dev                9510  1 lirc_mceusb
ir_rc5_decoder          1950  0 
snd_timer              19067  2 snd_pcm,snd_seq
rc_rc6_mce              1146  0 
snd_seq_device          5744  3 snd_seq_midi,snd_rawmidi,snd_seq
ir_nec_decoder          2014  0 
ivtv                  141210  0 
ppdev                   5556  0 
mceusb                 11494  0 
i2c_algo_bit            5168  1 ivtv
ir_core                14654  8 ir_sony_decoder,ir_jvc_decoder,ir_rc6_decoder,ir_rc5_decoder,rc_rc6_mce,ir_nec_decoder,mceusb
parport_pc             26058  1 
gspca_stv06xx          23798  0 
amd64_agp               7433  1 
gspca_main             23644  1 gspca_stv06xx
snd                    49006  21 snd_via82xx,snd_ac97_codec,snd_usb_audio,snd_pcm,snd_mpu401_uart,snd_hwdep,snd_usbmidi_lib,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
cx2341x                12385  1 ivtv
v4l2_common            17329  5 wm8775,tuner,cx25840,ivtv,cx2341x
soundcore                880  1 snd
k8temp                  3132  0 
videodev               43098  6 wm8775,tuner,cx25840,ivtv,gspca_main,v4l2_common
v4l1_compat            13359  1 videodev
i2c_viapro              5777  0 
agpgart                32011  2 nvidia,amd64_agp
shpchp                 29886  0 
tveeprom               11178  1 ivtv
lp                      7342  0 
parport                31492  3 ppdev,parport_pc,lp
usbhid                 36882  0 
hid                    67742  1 usbhid
via_rhine              19038  0 
floppy                 54311  0 
pata_via                7300  0 
mii                     4425  1 via_rhine
sata_via                7344  4

Ca a l'air bon non ?

et une partie de cat /proc/bus/input/devices :

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="Media Center Ed. eHome Infrared Remote Transceiver (0609:0334)"
P: Phys=usb-0000:00:10.0-2/input0
S: Sysfs=/devices/virtual/rc/rc0/input4
U: Uniq=
H: Handlers=kbd event4 
B: EV=100003
B: KEY=fff 0 0 0 108fc326 2176041 0 0 0 0 118000 4180 100001 9e9680 0 0 10000000

et mon fichier hardware.conf :

# /etc/lirc/hardware.conf
#
#Chosen Remote Control
REMOTE="Windows Media Center Transceivers/Remotes (all)"
REMOTE_MODULES="lirc_dev mceusb"
REMOTE_DRIVER=""
REMOTE_DEVICE="/dev/lirc0"
REMOTE_LIRCD_CONF="mceusb/lircd.conf.mceusb"
REMOTE_LIRCD_ARGS=""

#Chosen IR Transmitter
TRANSMITTER="Microsoft Windows Media Center V2 (usb) : Scientific Atlanta Cable box"
TRANSMITTER_MODULES="lirc_dev mceusb"
TRANSMITTER_DRIVER=""
TRANSMITTER_DEVICE=""
TRANSMITTER_LIRCD_CONF="scientificatlanta/general.conf"
TRANSMITTER_LIRCD_ARGS=""

#Enable lircd
START_LIRCD="true"

#Don't start lircmd even if there seems to be a good config file
#START_LIRCMD="false"

#Try to load appropriate kernel modules
LOAD_MODULES="false"

# Default configuration files for your hardware if any
LIRCMD_CONF=""

#Forcing noninteractive reconfiguration
#If lirc is to be reconfigured by an external application
#that doesn't have a debconf frontend available, the noninteractive
#frontend can be invoked and set to parse REMOTE and TRANSMITTER
#It will then populate all other variables without any user input
#If you would like to configure lirc via standard methods, be sure
#to leave this set to "false"
FORCE_NONINTERACTIVE_RECONFIGURATION="false"
START_LIRCMD=""
REMOTE_SOCKET=""
TRANSMITTER_SOCKET=""

Merci A+


Pour tout connaître sur ma configuration : http://mythtv-fr.tuxfamily.org/wiki/utilisateur/king76

Hors ligne

#20 26/10/2010 13:44:18

gilles74
Administrateur, expert MythTVExpert en configuration du DVB-SAT., développeurMembre de l'équipe de traduction, s'occupe de l'adaptation francophone de accuweather.
Inscription : 20/02/2008
Messages : 3 914
Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

je suis partagé entre 2 solutions, je crois que c'est hal le gestionnaire de matériel qui met le bazar

dé-active le scan de hal pour le récepteur en suivant cette page

puis tu redemarres et testes avec irw

Hors ligne

#21 26/10/2010 13:53:22

king76
Membre
Lieu : Québec
Inscription : 17/08/2009
Messages : 136
Site Web Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

Merci à toi, je vais regarder cela ce soir... sur ma bécane..


Pour tout connaître sur ma configuration : http://mythtv-fr.tuxfamily.org/wiki/utilisateur/king76

Hors ligne

#22 26/10/2010 17:46:28

Ookaze
Expert MythTVMembre de l'équipe de traduction et traducteur de la documentation.
Inscription : 15/01/2008
Messages : 884
Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

Bon, je ne dis pas que vous faites des conneries, je dis qu'en ce moment, c'est le PIRE moment pour faire des modifications de distribution pour MythTV. Je ne maîtrise pas les distributions, je ne sais pas ce qu'elles font, c'est aussi pour cela que je n'en utilise pas pour MythTV, mais malheureusement, il faut bien tout comprendre à un niveau assez bas du système pour comprendre ce qui se passe, or une distribution n'est pas faite pour ça. Il faut bien voir qu'en ce moment, il y a au moins 3 changements majeurs qui impactent MythTV d'une façon ou d'une autre selon votre configuration matérielle :
- passage de modules noyau LIRC dans le noyau Linux officiel
- mise à jour partielle de LIRC avec de nouvelles API pour accéder au noyau
- mise à jour de XOrg avec abandon complet de hal et passage via udev, et nouveau type de configuration

Je peux déjà dire qu'une grande quantité de tutoriels vont être ou sont déjà complètement obsolètes, alors qu'ils étaient encore fonctionnels en linux 2.6.35.
Je l'ai déjà expliqué dans un autre post, mais il est possible, si votre télécommande utilise l'interface event du noyau, que vous soyiez court-circuité (comme c'était le cas chez moi) par XOrg, qui va placer votre télécommande dans la classe "clavier", et bousiller ainsi tout le comportement. On peut le voir dans les logs du serveur X si c'est le cas.
Dans les dernières version de Xorg (1.9), la configuration a changé, et je pourrai toujours fournir les configurations que j'ai mis en place pour corriger ce problème s'il s'avère que vous avez le même.

Dans ce cas, c'est un bug de la distribution, mais vous êtes tributaires de qqn qui va comprendre le problème, le remonter avec une éventuelle correction, attendre la correction et le paquet qui va avec, et le réinstaller. C'est en cela que je parlais de "comprendre ce que l'on fait", et je conçois que ce n'est pas évident sur une distribution (j'ai laissé tomber il y a des années). Personnellement j'y arrive parce que je connais mes systèmes par coeur vu que c'est moi qui les construit, et donc je me suis aperçu que la période actuelle n'est pas évidente pour MythTV.

Hors ligne

#23 26/10/2010 19:22:05

gilles74
Administrateur, expert MythTVExpert en configuration du DVB-SAT., développeurMembre de l'équipe de traduction, s'occupe de l'adaptation francophone de accuweather.
Inscription : 20/02/2008
Messages : 3 914
Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

Je suis bien conscient du problème, c'est bien pour cela que j'ai parlé de 2 solutions. Effectivement je pense que la majeure partie des récepteurs IR utilisent les events avec les nouveaux noyaux, mais je ne suis pas sûr que les anciens fichiers de configuration soient encore valables ce qui peut induire une ré-écriture complète de ceux-ci.

Dans le cas précis, il semble que les anciens modules soient toujours opérationnels, j'ai donc proposé d'"empêcher" hal (toujours présent sur les distributions) de monter le module qui génère les events pour se retrouver dans la situation antérieure. Mais c'est une solution provisoire qui a le mérite d'être rapide si elle fonctionne mais qui ne traite pas le problème de fond qu'effectivement peu de gens connaissent

Dans le cas, ou l'on utilise les events, il y a 2 écoles, l'utilisation de lirc avec un fichier de configuration pour faire correspondre les events aux touches(comme avant), et l'utilisation du Xorg pour assimiler la télécommande à un clavier mais dans ce cas toutes les touches ne sont pas reconnues et il faut introduire ces touches dans le fichier d'interprétation du clavier (faisable mais pas simple car peu documenté) ensuite on peut se passer de lirc.

Hors ligne

#24 26/10/2010 19:49:21

natrio
Membre
Inscription : 12/11/2008
Messages : 90
Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

Oulala, ça m'a l'aire bien compliqué tout cela... En effet toutes ces évolution semble indiquer qu'il serai préférable de rester en 10.04 et attendre que tout ces défauts de jeunesses se résolvent...
En attendant je vous envoi les retour de commande suggérée, par contre vu mon niveaux d'anglais je vais mettre un peu plus de temps pour comprendre comment désactiver HAL. Je donnerai un feedback lorsque se sera fait.

Le retour de la commande lsmod

Module                  Size  Used by
nls_iso8859_1           4657  0
nls_cp437               6375  0
vfat                   10954  0
fat                    56244  1 vfat
usb_storage            50372  0
rfcomm                 40755  4
sco                     9954  2
bnep                   11985  2
l2cap                  42304  16 rfcomm,bnep
ir_lirc_codec           3888  0
lirc_dev               11209  1 ir_lirc_codec
ir_sony_decoder         2381  0
ir_jvc_decoder          2442  0
ir_rc6_decoder          3018  0
nvidia              10221046  44
snd_hda_codec_via      62447  1
snd_hda_intel          26019  3
snd_hda_codec         100919  2 snd_hda_codec_via,snd_hda_intel
snd_hwdep               6660  1 snd_hda_codec
snd_pcm                89104  3 snd_hda_intel,snd_hda_codec
snd_seq_midi            5932  0
arc4                    1497  2
snd_rawmidi            22207  1 snd_seq_midi
dvb_usb_dib0700        78922  20
snd_seq_midi_event      7291  1 snd_seq_midi
rt61pci                21534  0
snd_seq                57512  2 snd_seq_midi,snd_seq_midi_event
crc_itu_t               1739  1 rt61pci
rt2x00pci               6993  1 rt61pci
dib7000p               19538  2 dvb_usb_dib0700
dib0090                15440  1 dvb_usb_dib0700
dib7000m               15995  1 dvb_usb_dib0700
rt2x00lib              31575  2 rt61pci,rt2x00pci
psmouse                62080  0
dib0070                 9367  2 dvb_usb_dib0700
dvb_usb                16765  1 dvb_usb_dib0700
led_class               3393  1 rt2x00lib
ir_rc5_decoder          2474  0
rc_imon_pad             1729  0
btusb                  12929  2
snd_timer              23850  2 snd_pcm,snd_seq
mac80211              266657  2 rt2x00pci,rt2x00lib
dib8000                29474  1 dvb_usb_dib0700
ir_nec_decoder          2442  0
dvb_core              105239  3 dib7000p,dvb_usb,dib8000
snd_seq_device          6912  3 snd_seq_midi,snd_rawmidi,snd_seq
dib3000mc              13147  1 dvb_usb_dib0700
dibx000_common          3880  4 dib7000p,dib7000m,dib8000,dib3000mc
imon                   24845  0
bluetooth              59213  9 rfcomm,sco,bnep,l2cap,btusb
ir_core                16906  9 ir_lirc_codec,ir_sony_decoder,ir_jvc_decoder,ir_rc6_decoder,ir_rc5_decoder,rc_imon_pad,ir_nec_decoder,imon
joydev                 11363  0
cfg80211              170293  2 rt2x00lib,mac80211
snd                    64117  14 snd_hda_codec_via,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
eeprom_93cx6            1789  1 rt61pci
serio_raw               4910  0
asus_atk0110           12987  0
soundcore               1240  1 snd
snd_page_alloc          8588  2 snd_hda_intel,snd_pcm
intel_agp              32080  0
lp                     10201  0
parport                37032  1 lp
usbhid                 42062  0
hid                    84678  1 usbhid
floppy                 65299  0
r8169                  42222  0
mii                     5261  1 r8169
pata_marvell            3345  1

Retour de la commande cat /proc/bus/input/devices

I: Bus=0003 Vendor=15c2 Product=0034 Version=0016
N: Name="iMON Remote (15c2:0034)"
P: Phys=usb-0000:00:1a.0-1/input0
S: Sysfs=/devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1:1.0/rc/rc0/input4
U: Uniq=
H: Handlers=kbd mouse1 event4
B: EV=100007
B: KEY=fff 0 400000108c0320 2d5008200000000 30000 400119000 419614100801 809e168000000000 200000010004002
B: REL=103

Voila une partie du log concernat lirc dans /var/log/daemon.log.

Oct 25 19:28:04 media-center lircd-0.8.7-pre3[1165]: caught signal
Oct 25 19:28:04 media-center lircd-0.8.7-pre3[3439]: lircd(default) ready, using /var/run/lirc/lircd
Oct 25 19:28:06 media-center lircd-0.8.7-pre3[3439]: accepted new client on /var/run/lirc/lircd
Oct 25 19:28:06 media-center lircd-0.8.7-pre3[3439]: could not get file information for /dev/lirc0
Oct 25 19:28:06 media-center lircd-0.8.7-pre3[3439]: default_init(): No such file or directory
Oct 25 19:28:06 media-center lircd-0.8.7-pre3[3439]: Failed to initialize hardware
Oct 25 19:28:53 media-center lircd-0.8.7-pre3[3439]: accepted new client on /var/run/lirc/lircd
Oct 25 19:28:59 media-center lircd-0.8.7-pre3[3439]: removed client
Oct 25 19:34:29 media-center lircd-0.8.7-pre3[3439]: caught signal
Oct 25 19:34:29 media-center lircd-0.8.7-pre3[3515]: lircd(default) ready, using /var/run/lirc/lircd
Oct 25 19:34:31 media-center lircd-0.8.7-pre3[3515]: accepted new client on /var/run/lirc/lircd
Oct 25 19:34:31 media-center lircd-0.8.7-pre3[3515]: could not get file information for /dev/lirc0
Oct 25 19:34:31 media-center lircd-0.8.7-pre3[3515]: default_init(): No such file or directory
Oct 25 19:34:31 media-center lircd-0.8.7-pre3[3515]: Failed to initialize hardware
Oct 25 19:34:37 media-center lircd-0.8.7-pre3[3515]: accepted new client on /var/run/lirc/lircd
Oct 25 19:34:48 media-center lircd-0.8.7-pre3[3515]: removed client
Oct 25 20:10:49 media-center ntpd[1319]: kernel time sync status change 6001
Oct 25 20:20:13 media-center lircd-0.8.7-pre3[3515]: caught signal
Oct 25 20:20:48 media-center lircd-0.8.7-pre3[3784]: lircd(default) ready, using /var/run/lirc/lircd
Oct 25 20:20:49 media-center lircd-0.8.7-pre3[3784]: accepted new client on /var/run/lirc/lircd
Oct 25 20:20:49 media-center lircd-0.8.7-pre3[3784]: could not get file information for /dev/lirc0
Oct 25 20:20:49 media-center lircd-0.8.7-pre3[3784]: default_init(): No such file or directory
Oct 25 20:20:49 media-center lircd-0.8.7-pre3[3784]: Failed to initialize hardware
Oct 25 20:20:52 media-center lircd-0.8.7-pre3[3784]: accepted new client on /var/run/lirc/lircd
Oct 25 20:21:11 media-center lircd-0.8.7-pre3[3784]: removed client

Hors ligne

#25 26/10/2010 21:26:05

gilles74
Administrateur, expert MythTVExpert en configuration du DVB-SAT., développeurMembre de l'équipe de traduction, s'occupe de l'adaptation francophone de accuweather.
Inscription : 20/02/2008
Messages : 3 914
Mythbox

Re : [Résolu] Il faut que je réinstalle lirc ! Please

tu es comme ton petit copain, ta télécommande passe par des events

Essaye ceci:
arrête lircd puis lance la commande suivante en console

puis lance

lircd -H devinput -d /dev/input/event4 -n

tu devrais voir ça

lircd-0.8.7-CVS[17443]: garbage after 'name' token in line 9 ignored
lircd-0.8.7-CVS[17443]: lircd(devinput) ready, using /var/run/lirc/lircd

Dans un autre console, tu tapes "irw" et appuie sur les touches de ta télécommande

Hors ligne

Réponse rapide

Veuillez composer votre message et l'envoyer
Si vous êtes un être humain ne changez pas le contenu de ces deux champs.

Pied de page des forums

Propulsé par FluxBB

Webmasteur SnouF

Hébergé par Tuxfamily

Valid XHTML 1.0 Strict