#1 07/01/2017 18:26:02

lhebui
Lieu : Saint Martin des Bois
Inscription : 18/03/2008
Messages : 628
Mythbox

[résolu] suite à MAJ mythweb sur Jessie : plus d'accès

Bonsoir,

Je n'arrive plus sur le réseau local à me connecter à mythweb  après une mise à jour du paquet sur Jessie. (je ne sais pas pourquoi mais je m'attendais à des pb ...)

Erreur 403

You don't have permission to access /mythweb/tv/list on this server.

Apache/2.4.10 (Raspbian) Server at 192.168.1.200 Port 80

J'ai vérifié sur le seveur, pas de pb de connexion à mythfrontend. Le fichier /etc/mythtv/mythweb-mysql.conf, rien n'a changé. (j'avais fait une copie en .old)

Dans /var/log/apache/error ... la dernière ligne :

[Sat Jan 07 18:37:31.680064 2017] [authz_core:error] [pid 6225] [client 192.168.1.15:44998] AH01630: client denied by server configuration: /usr/share/mythtv/mythweb/tv

Désolé mais là, je ne trouve pas ...

Dernière modification par lhebui (12/01/2017 18:54:56)

Hors ligne

#2 07/01/2017 20:04:58

lhebui
Membre
Lieu : Saint Martin des Bois
Inscription : 18/03/2008
Messages : 628
Mythbox

Re : [résolu] suite à MAJ mythweb sur Jessie : plus d'accès

Je viens de changer les droits de mythweb-mysql.conf et mythweb.conf. Maintenant, ils sont 755.

Mais toujours le même pb ...

Hors ligne

#3 08/01/2017 10:48:31

lhebui
Membre
Lieu : Saint Martin des Bois
Inscription : 18/03/2008
Messages : 628
Mythbox

Re : [résolu] suite à MAJ mythweb sur Jessie : plus d'accès

Ce matin,

Je viens de vérifier si je pouvais me connecter avec mythweb en étant sur le serveur mythtv : oui.

Est-ce que je peux me connecter sur un autre poste sur le réseau local (autre que celui essayé hier) : non.

Donc je pense que j'ai sûrement un pb de droit. Maintenant, où ???

(j'arrive à me connecter sur phpmyadmin sur le serveur mythtv sur un autre poste en local)

Dernière modification par lhebui (08/01/2017 10:59:47)

Hors ligne

#4 08/01/2017 18:53:15

SnouF
Webmasteur, développeurDéveloppeur de scripts pour mythtv (tel que des grabbeurs pour MythNetVision). S'occupe également du dépôt deb des scripts mythtv-fr et propose un dépôt mythtv-fixes pour debian (stable, testing et unstable).
Inscription : 02/11/2007
Messages : 4 529
Site Web Mythbox

Re : [résolu] suite à MAJ mythweb sur Jessie : plus d'accès

Je pense que le problème se trouve du coté de la configuration apache.

/etc/apache2/conf-enabled/mythweb.conf a dût être modifier tu devrais avoir

...
        Order allow,deny
        Allow from localhost 127.0.0.1 ::1
        Satisfy any
...

Essaie d'ajouté après ::1 192.168.0 (ou 192.168.1 selon ta box). Puis redémarre apache

l'accès sera autorisé au tout les pc du réseau local.

[edit] Attention ! après cette modification à chaque mise a jours du paquet tu vas avoir une notification comme quoi un fichier de configuration a été modifié manuellement. Il y a peut-être plus propre comme méthode

Dernière modification par SnouF (08/01/2017 19:13:31)

Hors ligne

#5 08/01/2017 19:45:47

lhebui
Membre
Lieu : Saint Martin des Bois
Inscription : 18/03/2008
Messages : 628
Mythbox

Re : [résolu] suite à MAJ mythweb sur Jessie : plus d'accès

Merci pour ta réponse ...

Le fichier est un lien qui pointe sur un autre lien dans /etc/apache2/conf-avaible/ qui pointe sur le fichier mythweb.conf dans /etc/mythtv/mythweb.conf

Je n'ai pas trouvé dans ce fichier l'extrait que tu as mis ... Je te mets le contenu du fichier juste en-dessous :

#
# Apache configuration directives for MythWeb.  Please read INSTALL for setup
# requirements and troubleshooting, along with the comments in this file.
#

############################################################################
# If you intend to use authentication for MythWeb (see below), you will
# probably also want to uncomment the following rules, which disable
# authentication for MythWeb's download URLs so you can properly stream
# to media players that don't work with authenticated servers.
#
#    <LocationMatch .*/pl/stream/[0-9]+/[0-9]+>
#        Allow from all
#    </LocationMatch>
#
#    <LocationMatch .*/music/stream.php>
#        Allow from all
#    </LocationMatch>


#
# CHANGE THESE PATHS TO MATCH YOUR MYTHWEB INSTALLATION DIRECTORY!  e.g.
#
#    /var/www
#    /home/www/htdocs
#    /var/www/html/mythweb
#    /srv/www/htdocs/mythweb
#
    <Directory "/var/lib/mythtv/mythweb/data">
        Options +FollowSymLinks +IncludesNoExec
    </Directory>

    Alias /mythweb /usr/share/mythtv/mythweb

    <Directory "/usr/share/mythtv/mythweb" >

    ############################################################################
    # I *strongly* urge you to turn on authentication for MythWeb.  It is disabled
    # by default because it requires you to set up your own password file.  Please
    # see the man page for htdigest and then configure the following four directives
    # to suit your authentication needs.
    #
    #    AuthType           Digest
    #    AuthName           "MythTV@your.host.name"
    #    AuthUserFile       /etc/apache2/passwd-mythweb
    #    Require            valid-user
    #    BrowserMatch       "MSIE"      AuthDigestEnableQueryStringHack=On
    #
    #  * If you're running Apache earlier than 2.2, you will need to use
    #    the AuthDigestFile command instead of AuthUserFile (3rd line above).
    #
    #  In Debian, by default only the local machine is allowed to access
    #  mythweb. Enable the authentication lines above or some other
    #  authorisation scheme to allow other machines to access mythweb.

	Require local

    #
    ############################################################################
    # Some special instructions for the MythWeb controller files
    #
        <Files mythweb.*>

	Include /etc/mythtv/mythweb-mysql.conf

        #
        # By default, MythWeb uses the hostname program to look up the hostname of the
        # machine it runs on.  If this reports incorrect data, or you run MythWeb on a
        # machine without the hostname program, set this to your current hostname.
        #
        #   setenv hostname         "my_mythbox"
        #

        # By default, php will always search the current directory for include files,
        # but if you wish to install these directories outside of the current path
        # (eg. for security reasons), set this variable to the directory that
        # contains the directories like languages and templates.  eg.
        #
        #   setenv include_path      "/usr/share/mythweb"

        # If you want MythWeb to email php/database errors (and a backtrace) to you,
        # uncomment and set the email address below.
        #
        #   setenv error_email       "mythweb_errors@example.com"
        #

        # If your local file system is something other than UTF-8, set this variable
        # so that the music and video portions of MythWeb can provide proper links
        # to your downloadable files.
        #
        #   setenv fs_encoding       "ISO-8859-1"

        </Files>

    ############################################################################
    # The following settings relate to PHP config.
    #

        <Files *.php>

        #  These settings are intended for apache 2.x.  If your version of apache
        #  doesn't support php_value, or things like memory_limit aren't working
        #  as expected, then use these settings as examples for your own php.ini
        #  files.
#            php_value safe_mode                     0
#            php_value register_globals              0
#            php_value magic_quotes_gpc              0
            php_value file_uploads                  0
            php_value allow_url_fopen               On

            php_value zlib.output_handler           Off
#            php_value output_handler                NULL

        # If you have a large number of channels, you may need to increase
        # this value to prevent PHP from running out of memory during
        # searches.  The default is 64M.
            php_value memory_limit                  64M
#            php_value memory_limit                  128M
#            php_value memory_limit                  256M
#            php_value memory_limit                  512M

        # If you have a large number of channels, php may timeout creating
        # complex pages, so you will need to increase the amount of time
        # php has to create the page. The default is 30 seconds.
            php_value max_execution_time 30
#            php_value max_execution_time 60
#            php_value max_execution_time 120

        # Note: php_flag does not work in older versions of php
#            php_flag output_handler                 "NULL"

            php_value display_startup_errors        On
            php_value display_errors                On

        </Files>

    ############################################################################
    # The settings below relate specifically to mod_rewrite and the rewrite
    # engine used to make the MythWeb user experience a little easier to deal
    # with by simplifying the URLs needed to access the various sections.  Do
    # not touch these settings unless you really know what you're doing..
    #

    # Turn on the rewrite engine
        RewriteEngine  on

    # If MythWeb is installed outside of the document root (eg. using Alias) then
    # you will need to set this directive to the base URL that MythWeb is visible
    # from externally.  If you do not, the web server will return 'not found'.
    RewriteBase    /mythweb

    # Skip out early if we've already been through rewrites,
    # or if this is a /css/, /js/ or /cache/ directory request.
        RewriteRule    ^(css|data|images|js|themes|skins|README|INSTALL|[a-z_]+\.(php|pl))(/|$)     -     [L]

    # Redirect /pl/ requests to the perl cgi handler.
        RewriteRule     ^(pl(/.*)?)$            mythweb.pl/$1               [QSA,L]

    # Redirect most of the remaining URL requests to the main mythweb script.
    # It will then handle any requests given to it.
        RewriteRule     ^(.+)$                  mythweb.php/$1              [QSA,L]

    # If you're experiencing trouble with the previous two lines in your copy of
    # apache, you could instead use something like:
    #    RewriteRule     ^(pl(/.*)?)$           mythweb.pl?PATH_INFO=/$1    [L,QSA]
    #    RewriteRule     ^(.+)$                 mythweb.php?PATH_INFO=/$1   [L,QSA]

    # Catch anything else that comes through and send it to mythweb.php with no parameters.
        RewriteRule     ^(.*)$                  mythweb.php                 [QSA,L]

    ############################################################################
    # You really shouldn't need to edit anything below this line, so please
    # don't unless you know what you're doing.
    #

    # Allow .htaccess to override whatever it wants from the server config.
        AllowOverride   All

    # Allow browsers to follow symlinks that point outside of the web document
    # tree.  This is how we access music, videos, etc.
        Options         FollowSymLinks

    # MythTV now uses the correct file suffix for mpeg files, so all .nuv files
    # should actually be NuppleVideo.  However, apache probably doesn't know what
    # those are, so we should tell it.
        AddType video/nuppelvideo   .nuv

    # Specify the MIME type for favicon.ico in case the server configuration
    # doesn't or in case the server configuration uses the IANA-approved MIME type
    # (image/vnd.microsoft.icon)--which most browsers won't recognize.
        AddType image/x-icon        .ico

    # Enable mod_deflate.  This works MUCH more reliably than PHP's built-in
    # gzip/Zlib compressors.  It is disabled here because many distros seem not
    # to enable mod_deflate by default, but I strongly recommend that you
    # enable this section.
    #
    #    BrowserMatch ^Mozilla/4 gzip-only-text/html
    #    BrowserMatch ^Mozilla/4\.0[678] no-gzip
    #    BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    #
    #    AddOutputFilterByType DEFLATE text/html
    #    AddOutputFilterByType DEFLATE text/css
    #    AddOutputFilterByType DEFLATE application/x-javascript

    # This is helpful for mod_deflate -- it prevents proxies from changing
    # the user agent to/from this server, which can prevent compression from
    # being enabled.  It is disabled here because many distros seem not to
    # enable mod_headers by default, but I recommend that you enable it.
    #
    #    Header append Vary User-Agent env=!dont-vary

    # Set up the perl handler so we can stream properly.  Do not use mod_perl
    # because it has a tendency to hold onto child processes, which causes
    # problems if the browser closes on an in-progress stream.
    #
        <Files *.pl>
            SetHandler cgi-script
            Options +ExecCGI
        </Files>

    </Directory>

J'ai fait une recherche mais je n'ai rien trouvé d'approchant ...

Hors ligne

#6 10/01/2017 17:56:04

SnouF
Webmasteur, développeurDéveloppeur de scripts pour mythtv (tel que des grabbeurs pour MythNetVision). S'occupe également du dépôt deb des scripts mythtv-fr et propose un dépôt mythtv-fixes pour debian (stable, testing et unstable).
Inscription : 02/11/2007
Messages : 4 529
Site Web Mythbox

Re : [résolu] suite à MAJ mythweb sur Jessie : plus d'accès

mmmh autre version d'apache je pense (

    #  In Debian, by default only the local machine is allowed to access
    #  mythweb. Enable the authentication lines above or some other
    #  authorisation scheme to allow other machines to access mythweb.

	Require local

tu ajoutes une ligne https://httpd.apache.org/docs/trunk/mod … _host.html

Require ip 192.168.0
# ou Require ip 192.168.1 selon ta box

Hors ligne

#7 11/01/2017 18:39:02

lhebui
Membre
Lieu : Saint Martin des Bois
Inscription : 18/03/2008
Messages : 628
Mythbox

Re : [résolu] suite à MAJ mythweb sur Jessie : plus d'accès

Bon, j'ai essayé avec

Require ip 192.168.0

ou

Require ip 192.168.0.1

mais rien n'y fait.

A chaque fois, j'ai relancé apache au cas où ...

Hors ligne

#8 11/01/2017 19:16:22

SnouF
Webmasteur, développeurDéveloppeur de scripts pour mythtv (tel que des grabbeurs pour MythNetVision). S'occupe également du dépôt deb des scripts mythtv-fr et propose un dépôt mythtv-fixes pour debian (stable, testing et unstable).
Inscription : 02/11/2007
Messages : 4 529
Site Web Mythbox

Re : [résolu] suite à MAJ mythweb sur Jessie : plus d'accès

Si je prend ton 1er poste "[Sat Jan 07 18:37:31.680064 2017] [authz_core:error] [pid 6225] [client 192.168.1.15:44998] AH01630: client denied by server configuration: /usr/share/mythtv/mythweb/tv"
donc

Require ip 192.168.1

(sans le 0)

PS : je tâtonne souvent un peu avec la conf apache mais la je pense avoir bon.

Hors ligne

#9 12/01/2017 18:54:32

lhebui
Membre
Lieu : Saint Martin des Bois
Inscription : 18/03/2008
Messages : 628
Mythbox

Re : [résolu] suite à MAJ mythweb sur Jessie : plus d'accès

Effectivement, tu as raison ... Quelle burne je suis !!!

Maintenant, cela fonctionne. (j'étais persuadé que mon réseau était en 192.168.0. ...)

Un grand merci Snouf.

Bonne soirée.

Hors ligne

Réponse rapide

Veuillez composer votre message et l'envoyer
Si vous êtes un être humain ne changez pas le contenu de ces deux champs.

Pied de page des forums

Propulsé par FluxBB

Webmasteur SnouF

Hébergé par Tuxfamily

Valid XHTML 1.0 Strict