#1 25/02/2017 17:22:55

RichardOnMythTvFr
Inscription : 25/02/2017
Messages : 3

Frontend télé Sony et/ou Windows Media Player

Bonjour,

je me suis monté un backend sous linux 16.04. Tout fonctionne normalement(ou presque). Touts mes frontend Kodi essayés ont fonctionnés sans problème(Windows, Linux, Android, OSMC sur RPI).

Malheureusement, je suis incapable de l’accéder via WMP et/ou ma télé Sony. Bizarrement, sur cette dernière, je vois 2 titres qui en fait sont des enregistrements endommagés. Ceux-ci sont visible dans la liste mais leurs fichiers TS inexistants.

GetPlaybackURL: '1021_20170225010001.ts' should be local, but it can not be found.

Quelqu'un aurait une piste de solution a me fournir?

Merci à l'avance

Hors ligne

#2 26/02/2017 22:44:24

SnouF
Webmasteur, développeurDéveloppeur de scripts pour mythtv (tel que des grabbeurs pour MythNetVision). S'occupe également du dépôt deb des scripts mythtv-fr et propose un dépôt mythtv-fixes pour debian (stable, testing et unstable).
Inscription : 02/11/2007
Messages : 4 527
Site Web Mythbox

Re : Frontend télé Sony et/ou Windows Media Player

Bonjour

Linux 16.04 ? je suppose ubuntu 16.04. Par contra WMP je comprend pas.

Pour le TV sony je suppose que tu passes pas un client DLNA/UPNp. Je testerai avec un autre client (vlc par exemple) pour voir si le problème vient d'un format non supporté ou un problème de configuration (mais si c'est un problème de configuration et que le reste fonctionne je ne vois pas d'où ça peut venir).

Hors ligne

#3 27/02/2017 00:42:00

RichardOnMythTvFr
Membre
Inscription : 25/02/2017
Messages : 3

Re : Frontend télé Sony et/ou Windows Media Player

Bonjour,

effectivement je voulais dire Ubuntu 16.04.WMP était pour Windows Media Player. Je vais donc tenter d'ajouter certaines informations. Comme précédemment mentionné, j'ai fait plusieurs tentatives sous différents systèmes en utilisant MythTv addon sur Kodi. Ceux-ci ont toutes fonctionnés parfaitement. Mes problèmes arrivent quand j'utilise un autre type de client. WMP était cité qu'à titre de référence seulement car il ne fonctionne pas lui non plus et c'est peut-être pour les même raisons que ma télé Sony roulant un client DNLA/UPNp.

Cette dernière détecte mon MythBackend. Cependant, il affiche que quelques titres seulement. Bizarrement, ces titres affichés montrent toutes qu'ils sont endommagés quand questionnés via MythWeb. Ceux non-endommagés, ne figurent pas dans la liste retournée par le backend. Pour l'affichage de ces titres, je pense que c'est relié à la base de données. Est-il possible de voir les requêtes que la base reçoit pour les retourner. Ce serait peut-être une bonne piste de solution.

Aussi, comme mentionné dans mon post initial, les logs montraient que le fichier TS n'était pas présent. Même si ce n'était pas le bon, j'en ai placé un ayant ce nom. De ma télé, j'ai pu le partir. Je ne connais pas la structure de ce type de fichier mais au final, j'avais que la trame audio. Mais c'est peut-être aussi un problème de codec.

Mon plus grand défi vient du fait que je manque d'outils et de connaissances d'Ubuntu. Mes connaissances sont beaucoup plus sur Windows. Certains concepts peuvent s'apparenter mais c'est dans la façon de s'y rendre qui différent énormément.

Merci à l'avance. Toutes aides est grandement appréciée.

Hors ligne

#4 27/02/2017 19:17:36

SnouF
Webmasteur, développeurDéveloppeur de scripts pour mythtv (tel que des grabbeurs pour MythNetVision). S'occupe également du dépôt deb des scripts mythtv-fr et propose un dépôt mythtv-fixes pour debian (stable, testing et unstable).
Inscription : 02/11/2007
Messages : 4 527
Site Web Mythbox

Re : Frontend télé Sony et/ou Windows Media Player

Tient j'avais oublié l'existence de WMP big_smile mes dernières références dates de .... très longtemps (windows XP) mais c'était loin d'être une référence au niveau de format supporté.

Le client PVR pour Kodi n'utilise pas les fonctionnalités DLNA/UPNp, il se base sur une api spécifique à mythtv. Un problème coté serveur DLNA/UPNp est donc possible. Le truc c'est que les spécifications DLNA/UPNp sont assez vague, il est possible que WMA et ta TV sony ne soit pas compatible avec le serveur Mythtv. D'où la nécessité de faire un teste avec VLC qui je sais est compatible.

Tout tes enregistrements sont des .ts ? de mémoire j'avais des mpeg (aquisition DVB-T/IPTV) mais c'est probablement une histoire de matériel.

Je ne m'explique cependant pas pourquoi seules les fichiers "corrompu" sont visibles. Les fichier ts que tu as créé se trouve au même entrois que les autres enregistrements ?

Vérifie tes groupes de stockage dans mythtvsetup. Je ne vois que ça comme problème possible pour l'instant.

PS: J'avais testé les fonctions DNLA/UPNp avec un TV samsung techniquement ça fonctionnait (niveau ergonomie ce n'était pas très pratique).

Hors ligne

#5 28/02/2017 06:00:11

RichardOnMythTvFr
Membre
Inscription : 25/02/2017
Messages : 3

Re : Frontend télé Sony et/ou Windows Media Player

Que dois-je vérifier concernant les groupes de stockages. Ils sont toutes liés a un répertoire spécifique. Tout les enregistrements sont placés dans le même répertoire. Ceux-ci sont aussi lisible avec VLC.

moi@RVP-Myth:/var/lib/mythtv$ ls -l
total 48
drwxrwsr-x 2 mythtv mythtv 4096 fév 25 14:39 banners
drwxrwsr-x 2 mythtv mythtv 4096 jan 29 20:23 bare-client
drwxrwsr-x 2 mythtv mythtv 4096 fév 25 14:39 coverart
drwxrwsr-x 2 mythtv mythtv 4096 fév 26 07:40 db_backups
drwxrwsr-x 2 mythtv mythtv 4096 fév 25 14:39 fanart
drwxrwsr-x 2 mythtv mythtv 4096 fév 25 14:39 livetv
drwxrwxr-x 2 mythtv mythtv 4096 jan 29 20:08 mythexport
drwxrwsr-x 2 mythtv mythtv 4096 fév 26 20:08 recordings
drwxrwsr-x 2 mythtv mythtv 4096 fév 25 14:39 screenshots
drwxrwsr-x 2 mythtv mythtv 4096 jan 26 20:18 streaming
drwxrwsr-x 2 mythtv mythtv 4096 fév 25 14:39 trailers
drwxrwsr-x 2 mythtv mythtv 4096 fév 25 17:42 videos
@RVP-Myth:/var/lib/mythtv/recordings$ ls -l
total 10050352
-rw-r--r-- 1 mythtv mythtv 2058715056 fév  1 21:00 1021_20170202010000.ts
-rw-rw-rw- 1 mythtv mythtv       9150 fév  5 23:13 1021_20170202010000.ts.-1.100x56.png
-rw-rw-rw- 1 mythtv mythtv     516973 fév  1 21:22 1021_20170202010000.ts.png
-rw-r--r-- 1 mythtv mythtv 4637139944 fév 26 22:15 1021_20170227010000.ts
-rw-rw-rw- 1 mythtv mythtv        221 fév 26 20:08 1021_20170227010000.ts.-1.100x56.png
-rw-rw-rw- 1 mythtv mythtv       4337 fév 26 20:00 1021_20170227010000.ts.png
-rw-r--r-- 1 mythtv mythtv 3594758528 fév 26 21:33 1101_20170227003000.ts
-rw-rw-rw- 1 mythtv mythtv       8750 fév 26 19:39 1101_20170227003000.ts.-1.100x56.png
-rw-rw-rw- 1 mythtv mythtv     370541 fév 26 19:30 1101_20170227003000.ts.png

Edit SnouF : ajout balise de code

Hors ligne

#6 04/03/2017 16:27:23

SnouF
Webmasteur, développeurDéveloppeur de scripts pour mythtv (tel que des grabbeurs pour MythNetVision). S'occupe également du dépôt deb des scripts mythtv-fr et propose un dépôt mythtv-fixes pour debian (stable, testing et unstable).
Inscription : 02/11/2007
Messages : 4 527
Site Web Mythbox

Re : Frontend télé Sony et/ou Windows Media Player

Que dois-je vérifier concernant les groupes de stockages

Qu'il sont bien créer.

Coté vlc pour écarter la possibilité de problème du coté client UPnP il faut tester la lecture via la fonction UPnP de vlc wink (liste de lecture -> groupe "Réseau local" -> Universal Plug'n'Play)

Quel est la version de mythtv que tu utilises ? As-tu activé les autobuilds ? Car je ne pense pas que c'est une problème de lecteur ni un problème de config donc ... peut-être un bug.

Hors ligne

Réponse rapide

Veuillez composer votre message et l'envoyer
Si vous êtes un être humain ne changez pas le contenu de ces deux champs.

Pied de page des forums

Propulsé par FluxBB

Webmasteur SnouF

Hébergé par Tuxfamily

Valid XHTML 1.0 Strict