#1 30/08/2018 19:55:02

lhebui
Lieu : Saint Martin des Bois
Inscription : 18/03/2008
Messages : 665
Mythbox

[Résolu][trunk] En 0.29 pb de téléchargement avec mythweb

Sur le PI3, tout fonctionne sauf le téléchargement des prg enregistrés.

Je pense (j'en suis pratiquement sûr) que les enregistrements existent. Un détail qui n'en ai pas un ... Je suis passé de 0.28 à 0.29 pour mythtv. J'ai donc rechargé la base de données et je vois bien les enregistrements sur mythweb.

Par contre, quand je veux télécharger un enregistrement, je me retrouve devant un échec :

Not Found

The requested URL /mythweb/mythweb.pl/pl/stream/1007/1527971400 was not found on this server.
Apache/2.4.25 (Raspbian) Server at 192.168.1.200 Port 80

Si quelqu'un a une idée ?

Dernière modification par lhebui (03/09/2018 12:29:35)


RPI3+ en mythtv et TVHEADEND (en construction pour les 2 ...)

Hors ligne

#2 31/08/2018 09:35:56

lhebui
Membre
Lieu : Saint Martin des Bois
Inscription : 18/03/2008
Messages : 665
Mythbox

Re : [Résolu][trunk] En 0.29 pb de téléchargement avec mythweb

Je viens de vérifier le contenu de la table "storagegroup" dans mythconverg.
localhost/mythconverg/storagegroup/        http://192.168.1.200/phpmyadmin/sql.php … 13fb1cef2e
Affichage des lignes 0 - 12 (total de 13, Traitement en 0.0008 secondes.)

SELECT * FROM `storagegroup`


id	groupname	hostname	dirname	
12	Default	HP-Compaq-6000-Pro-SFF-PC	/media/VIDEO_2To/	
2	Videos	HP-Compaq-6000-Pro-SFF-PC	/var/lib/mythtv/videos/	
3	Fanart	HP-Compaq-6000-Pro-SFF-PC	/var/lib/mythtv/fanart/	
4	Trailers	HP-Compaq-6000-Pro-SFF-PC	/var/lib/mythtv/trailers/	
5	Coverart	HP-Compaq-6000-Pro-SFF-PC	/var/lib/mythtv/coverart/	
7	Screenshots	HP-Compaq-6000-Pro-SFF-PC	/var/lib/mythtv/screenshots/	
8	Banners	HP-Compaq-6000-Pro-SFF-PC	/var/lib/mythtv/banners/	
9	DB Backups	HP-Compaq-6000-Pro-SFF-PC	/var/lib/mythtv/db_backups/	
13	LiveTV	HP-Compaq-6000-Pro-SFF-PC	/media/VIDEO_2To/live_tv/	
11	Streaming	HP-Compaq-6000-Pro-SFF-PC	/var/lib/mythtv/streaming/	
18	Default	raspberrypi	/media/video/video/	
21	LiveTV	raspberrypi	/media/mythtv_live/	
19	DB Backups	raspberrypi	/media/video/svgde_mythconverg/	

Ce qui m'étonne est que la base conserve l'historique depuis que j'ai créé mythtv sur le HP-Compaq ...


RPI3+ en mythtv et TVHEADEND (en construction pour les 2 ...)

Hors ligne

#3 31/08/2018 20:50:02

SnouF
Webmasteur, développeurDéveloppeur de scripts pour mythtv (tel que des grabbeurs pour MythNetVision). S'occupe également du dépôt deb des scripts mythtv-fr et propose un dépôt mythtv-fixes pour debian (stable, testing et unstable).
Inscription : 02/11/2007
Messages : 4 558
Site Web Mythbox

Re : [Résolu][trunk] En 0.29 pb de téléchargement avec mythweb

Et les enregistrements existe bien dans les dossiers ?

Regarde si le module perl est activé,

# a2enmod cgi
# a2enmod perl

Qu'est ce que donne
http://IP//mythweb/mythweb.pl

Hors ligne

#4 01/09/2018 21:43:35

lhebui
Membre
Lieu : Saint Martin des Bois
Inscription : 18/03/2008
Messages : 665
Mythbox

Re : [Résolu][trunk] En 0.29 pb de téléchargement avec mythweb

Les fichiers existent bien dans le répertoire concerné pour les champs 18, 19 et 21 de la table "storagegroup".

sudo a2enmod cgi
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
Enabling module cgi.
To activate the new configuration, you need to run:
  systemctl restart apache2
sudo a2enmod perl
ERROR: Module perl does not exist!

J'ai donc installé libapache2-mod-perl2 (2.0.10-2) et le dev en même temps ...

sudo a2enmod perl
Module perl already enabled

Donc je dois être sur le bon chemin ... Un petit systemctl restart apache2.service

sudo systemctl restart apache2.service

Le retour de "http://IP//mythweb/mythweb.pl" avec le bon IP naturellement :

#!/usr/bin/perl -w
#
# This is the perl-based module handler.  It is the counterpart of mythweb.php
#
#

# Load some required modules
    use CGI qw/:standard/;
    use DBI;
    use Cwd 'abs_path';
    use File::Basename;

# Add mythweb dir to @INC
    use lib dirname(abs_path($ENV{'SCRIPT_FILENAME'} or $0));

# pwd is / when running under mod_rewrite, so we should chdir to the script
# directory for consistency
    chdir dirname(abs_path($ENV{'SCRIPT_FILENAME'} or $0));

# Don't forget to include the current directory in the search path.
    substr($ENV{'PATH'}, 0, 0) = '.:';

# Create a cgi object;
    our $cgi = new CGI;

# Extract the requested path
    our @Path;
    $Path[0] = ($ENV{'PATH_INFO'} or url_param('PATH_INFO'));
    $Path[0] =~ s#^/+##sg;
    $Path[0] =~ s#\s+$##sg;
    @Path = split('/', $Path[0]);
    shift @Path if ($Path[0] eq 'pl');

# Figure out the root web directory
    our $web_root = dirname($ENV{'SCRIPT_NAME'}).'/';
    $web_root =~ s#//#/#g;

# Add a directory to the search path?
    if ($ENV{'include_path'}) {
        $ENV{'PATH'} .= ':'.$ENV{'include_path'};
    }

# Work around a lighttpd bug:  http://trac.lighttpd.net/trac/ticket/420
    foreach my $key (keys %ENV) {
        $ENV{lc($key)} = $ENV{$key} if ($key =~ m/DB_/);
    }

# Connect to the database
    END { $dbh->disconnect() if ($dbh); }
    our $dbh = DBI->connect("dbi:mysql:database=$ENV{'db_name'}:host=$ENV{'db_server'}",
                            $ENV{'db_login'},
                            $ENV{'db_password'});
    unless ($dbh) {
        print header(),
              "Cannot connect to database: $!\n\n";
        exit;
    }
# Set database connection to utf8
    $dbh->prepare("SET NAMES utf8;")->execute();
# Make sure UNIX_TIMESTAMP AND FROM_UNIXTIME do the right things
    $dbh->prepare("SET time_zone='+0:00';")->execute();

# Find the path to the modules directory
    our $modules_dir = dirname(dirname(find_in_path('modules/tv/init.php')));

# Figure out what the user is trying to do
    if ($Path[0]) {
        if (-e "$modules_dir/$Path[0]") {
            if (-e "$modules_dir/$Path[0]/handler.pl") {
                require "modules/$Path[0]/handler.pl";
            }
            else {
                print header(),
                      "Module '$Path[0]' doesn't have a perl handler.";
            }
        }
        elsif ($Path[0] =~ /\w/) {
            print header(),
                  "Unknown module:  $Path[0]";
        }
    }
    else {
        print header(-location => $web_root);
        print " \n";
    }

# Exit nicely
    exit;

################################################################################

# Find a file in the current include path
    sub find_in_path {
        my $file = shift;
    # Split out each of the search paths
        foreach my $path (@INC, split(/:/, $ENV{'PATH'})) {
        # Formulate the absolute path
            my $full_path = "$path/$file";
        # Exists?
            return $full_path if (-e $full_path);
        }
        return undef;
    }

Et maintenant j'essaie ...

Et tout fonctionne maintenant.

Merci Snouf. Ne reste plus maintenant à résoudre les pb avec hts : https://mythtv-fr.org/forums/viewtopic. … 684#p25684


RPI3+ en mythtv et TVHEADEND (en construction pour les 2 ...)

Hors ligne

#5 14/09/2018 16:55:37

SnouF
Webmasteur, développeurDéveloppeur de scripts pour mythtv (tel que des grabbeurs pour MythNetVision). S'occupe également du dépôt deb des scripts mythtv-fr et propose un dépôt mythtv-fixes pour debian (stable, testing et unstable).
Inscription : 02/11/2007
Messages : 4 558
Site Web Mythbox

Re : [Résolu][trunk] En 0.29 pb de téléchargement avec mythweb

Je pense qu'il s'agit d'un bug de paquet pour mythweb. Ces opération devrait être automatisée avec un paquet bien fait.

Hors ligne

Réponse rapide

Veuillez composer votre message et l'envoyer
Si vous êtes un être humain ne changez pas le contenu de ces deux champs.

Pied de page des forums

Propulsé par FluxBB

Webmasteur SnouF

Hébergé par Tuxfamily

Valid XHTML 1.0 Strict