#1 24/05/2020 19:42:31

Julius22
Membre
Lieu : Moirans
Inscription : 10/07/2011
Messages : 71
Mythbox

[Résolu] Problème de connexion au serveur

Bonjour,

Sur un ordinateur destiné à être serveur maître et frontal sous Debian 10, je ne parviens pas à me connecter au backend lors du lancement de mythfrontend.

Avec MariaDB, j'ai saisi les commandes ci-dessous.

GRANT ALL PRIVILEGES ON mythconverg.* TO 'mythtv'@'192.168.10.%' IDENTIFIED BY 'mot de passe';
GRANT ALL PRIVILEGES ON mythconverg.* TO 'mythtv'@'127.0.0.1' IDENTIFIED BY 'mot de passe';
GRANT ALL PRIVILEGES ON mythconverg.* TO 'mythtv'@'localhost' IDENTIFIED BY 'mot de passe';
UPDATE user SET Password=PASSWORD('mot de passe') WHERE user='mythtv';
FLUSH PRIVILEGES;

J'ai aussi essayé ce qui suit.

GRANT ALL PRIVILEGES ON mythconverg.* TO 'mythtv'@'192.168.10.%' IDENTIFIED BY 'mot de passe' WITH GRANT PRIVILEGES;
GRANT ALL PRIVILEGES ON mythconverg.* TO 'mythtv'@'127.0.0.1' IDENTIFIED BY 'mot de passe' WITH GRANT PRIVILEGES;
GRANT ALL PRIVILEGES ON mythconverg.* TO 'mythtv'@'localhost' IDENTIFIED BY 'mot de passe' WITH GRANT PRIVILEGES;
UPDATE user SET Password=PASSWORD('mot de passe') WHERE user='mythtv';
FLUSH PRIVILEGES;

Mon ordinateur a une adresse IP fixe en 192.168.10.xyz. Il a un nom d'hôte que je lui ai donné. Dans les réglages de MythTV pour le serveur, j'ai a priori bien saisi tout ça. D'ailleurs, en tant qu'utilisateur administrateur, je n'ai pas de problème pour utiliser mythtv-setup. Avec la commande ci-dessous, les tables de la base de données apparaissent bien avec « OK ».

mysqlcheck --user=mythtv --password=mot de passe mythconverg

Mais avec mythfrontend, rien à faire, ça ne veut pas se connecter en indiquant les erreurs et informations qui suivent.

E [DBManager0] Unable to connect to database!
E Driver error was [1/1045]: QMYSQL:
Unable to connect
Database error was:
Access denied for user 'mythtv'@'localhost' (using password: YES)
I Start up testing connections, DB Sutiwora, BE 192.168.10.xyz, attempt 2, status beAwake, Delay: 2000
I MythCoreContext::ConnectCommandSocket(): Connecting to backend server: 192.168.10.xyz:6543 (try 1 of 1)
E MythSocket(7f47c00abf0:-1): Failed to connect to (127.0.0.1:6543) Connection refused
E Connection to master server timed out.
Either the server is down or the master server settings in mythtv-settings does not contain the proper IP address
A Cannot connect to backend
E Failed to init MythContext, exiting.

Quelqu'un⋅e a-t-il⋅elle une idée de ce qui peut poser problème ?

Modification du 29 mai 2020 : modification du sujet pour indiquer qu'il est résolu.

Dernière modification par Julius22 (29/05/2020 17:14:11)


Regardez l'utilisation de votre processeur et pensez à utiliser BOINC.

Hors ligne

#2 29/05/2020 17:13:05

Julius22
Membre
Lieu : Moirans
Inscription : 10/07/2011
Messages : 71
Mythbox

Re : [Résolu] Problème de connexion au serveur

Après avoir posté un message sur le même sujet sur le forum de mythtv.org, j'ai pu résoudre mon problème après avoir obtenu une réponse (cf. https://forum.mythtv.org/viewtopic.php?f=36&t=3825 (en anglais)). Visiblement, il me manquait la ligne avec LocalHostName dans le fichier /etc/mythtv.config.xml. C'est aussi simple que ça !


Regardez l'utilisation de votre processeur et pensez à utiliser BOINC.

Hors ligne

Réponse rapide

Veuillez composer votre message et l'envoyer
Si vous êtes un être humain ne changez pas le contenu de ces deux champs.

Pied de page des forums

Propulsé par FluxBB

Webmasteur SnouF

Hébergé par Tuxfamily

Valid XHTML 1.0 Strict