#1 26/12/2015 14:08:15

sciemo
Membre
Inscription : 20/06/2012
Messages : 63
Mythbox

[RESOLU] [0.27] Problème double tuner

Bonjour,
j'ai une carte: Hauppauge WinTV Nova TD 500 PCI (Double Tuner TNT)
Je ne sais pas quand le problème est apparue mais j'ai été obligé de supprimer une carte d'acquisition car mes 4 tuners se mettaient en erreur et la liaison avec le backend rencontrait également des problèmes.
Je me retrouve qu'avec 2 tuners pour pouvoir enregistrer et regarder sur le même multiplex.
D'ou peu venir le problème??

Merci de votre aide.

Dernière modification par sciemo (14/01/2016 14:51:12)

Hors ligne

#2 26/12/2015 18:51:41

gilles74
Administrateur, expert MythTVExpert en configuration du DVB-SAT., développeurMembre de l'équipe de traduction, s'occupe de l'adaptation francophone de accuweather.
Inscription : 20/02/2008
Messages : 3 914
Mythbox

Re : [RESOLU] [0.27] Problème double tuner

bonjour,
il est fort probable que ce soit lié à un problème de synchronisation au démarrage et que le backend soit lancé avant que la carte soit montée. Pour confirmer, tu peux relancer le backend après la séquence de démarrage; si tes 4 tuners apparaissent à ce moment là, le diagnostic est clair sinon il faut chercher ailleurs.

Est ce que ta distribution utilise systemd ?

Hors ligne

#3 28/12/2015 14:34:45

sciemo
Membre
Inscription : 20/06/2012
Messages : 63
Mythbox

Re : [RESOLU] [0.27] Problème double tuner

Merci gilles74 de ta réponse.
J'ai donc suivi ton conseil:
1) redémarrage complet de la mythbox,
2) lancement de mythFrontend => Tuner 1 est en erreur; Tuner 2 est en erreur
3) en lancant le liveTv => popup => Connexion au backend maitre impossible...
4) Je quitte MythFrontend, je lance une console avec la commande top et je vois que MythBackend tourne. Je relance MythFrontendv => idem que 2

je cherche et je m'aperçois que j'ai 3 enregistrements en erreur (E), j'en efface 2 et lance le 3ème. Après un moment assez long, je visionne l'enregistrement. J'arrête et retourne sur le liveTV et l'a tout fonctionne.
Qu'elle est le lien entre les enregistrements et le live??
Ma distri: MythBuntu 14.04 LTS donc pas de systemd

Hors ligne

#4 02/01/2016 22:14:30

SnouF
Webmasteur, développeurDéveloppeur de scripts pour mythtv (tel que des grabbeurs pour MythNetVision). S'occupe également du dépôt deb des scripts mythtv-fr et propose un dépôt mythtv-fixes pour debian (stable, testing et unstable).
Inscription : 02/11/2007
Messages : 4 564
Site Web Mythbox

Re : [RESOLU] [0.27] Problème double tuner

Bonjour

Pas de systemd sur 14,04 ? tu es sur tu peu vérifier en faisant un ps -A et en regardant regardant le PID 1
Essaie de lancer mybackend dans une console

#sh
#en live des erreurs de typos sont probables
sudo service mythtv-backend stop
mythbackend.real #important le .real !!!

Hors ligne

#5 06/01/2016 16:25:56

sciemo
Membre
Inscription : 20/06/2012
Messages : 63
Mythbox

Re : [RESOLU] [0.27] Problème double tuner

Bonjour SnouF,
La commande

ps -A

me renvois en PID 1: init
J'ai suivi ton conseil

sudo service mythtv-backend stop

cette commande n'est pas acceptée.
donc j'ai fait

killall mythbackend

Pour redémarrer comme tu me l'as conseillé:

mythbackend.real

mais elle n'est pas acceptée également.
J'ai donc fais

mythbackend

et mon problème persiste, 1seul tuner disponible.
Si vous avez d'autres conseils, je ne voudrais pas tout réinstaller
Par avance merci

Hors ligne

#6 07/01/2016 00:01:48

gilles74
Administrateur, expert MythTVExpert en configuration du DVB-SAT., développeurMembre de l'équipe de traduction, s'occupe de l'adaptation francophone de accuweather.
Inscription : 20/02/2008
Messages : 3 914
Mythbox

Re : [RESOLU] [0.27] Problème double tuner

extrait de linuxtv

Losing one tuner?
There are reports of the system losing one of the 2 tuners. This behaviour could be caused by the USB sub-system going to sleep/suspend.
A work-around is to pass a parameter to the usbcore kernel module, asking it to disable its suspend capability.
Edit the /etc/modprobe.d/options file and add:
options usbcore autosuspend=-1
or if you are using Ubuntu 9.04 onwards
Edit the /etc/modprobe.d/options.conf file and add:
options usbcore autosuspend=-1
If you are using a Debian-based distribution, you may need to rebuild your initrd and reboot for this to take effect as per this post.
If your kernel has usbcore built-in (e.g. Fedora Core 8, Ubuntu 12.04) and not as a module, you will have to modify your boot loader config to pass the parameter to the kernel at boot time by adding the following to your kernel boot line in your GRUB or LILO config:
usbcore.autosuspend=-1
More information about this is available on this mailing list post.
Another solution has been given for MythTV users and is worth trying:
MythTV has a parameter to delay the tuning of channels in the same configuration screen where you select active/passive EIT scanning. More precisely, it's at the right of the Active EIT scanning checkbox. I have adapter0 with passive EIT scanning, and 0 delay, and adapter1 with Active EIT scanning and 150ms of tuning delay. That solved the tuner-losing stuff and also I have my EIT fully populated.
More information about this is available on this mailing list post.
There is a step-by-step guide on how to setup MythTV and achieve tuner stability here.

Hors ligne

#7 07/01/2016 18:21:21

SnouF
Webmasteur, développeurDéveloppeur de scripts pour mythtv (tel que des grabbeurs pour MythNetVision). S'occupe également du dépôt deb des scripts mythtv-fr et propose un dépôt mythtv-fixes pour debian (stable, testing et unstable).
Inscription : 02/11/2007
Messages : 4 564
Site Web Mythbox

Re : [RESOLU] [0.27] Problème double tuner

sciemo a écrit :

me renvois en PID 1: init

donc tu avais raison ce n'est pas systemd

Le but de lancer mythbackend dans un terminal est d'avoir les logs, c'est normale que le problème persiste".

Tu as des logs quand tu lances mythbackend ? Sinon regarde quel est la commande en faisant un

#sh
ls /usr/bin/ | grep myth

tu devrais avoir quelque chose se similaire à "mythbackend.real"

Ou alors regarde la doc de mythbuntu je crois que les log sont expédié quelque part, peut-être dans le "mythbuntu control center" si ce truc existe toujours.

Hors ligne

#8 14/01/2016 11:44:00

sciemo
Membre
Inscription : 20/06/2012
Messages : 63
Mythbox

Re : [RESOLU] [0.27] Problème double tuner

Bonjour,
Mon problème est résolu (en grande partie).
- Dans Mythbackend, j'ai déclaré un second tuner
- J'ai donc créé un fichier options.conf dans: /etc/modprobe.d/
et j'ai ajouté:
options usbcore autosuspend=-1
- J'ai redémarré
- J'ai lancé mythfrontend et vérifier l'état de mes tuners. Ils étaient tous sur "n'enregistre pas" et tout à coup, un popup s'ouvre me disant que le backend est inactif. Je veux lancer le live, mais même popup.
- je quitte mythfrontend et je lance dans une console

mythbackend

- je relance mythfrontend et la tout fonctionne.

Merci de votre aide et du lien
NOTA-T 500

Hors ligne

#9 15/01/2016 23:56:07

gilles74
Administrateur, expert MythTVExpert en configuration du DVB-SAT., développeurMembre de l'équipe de traduction, s'occupe de l'adaptation francophone de accuweather.
Inscription : 20/02/2008
Messages : 3 914
Mythbox

Re : [RESOLU] [0.27] Problème double tuner

J'ai le même problème que toi, c'est à dire que si je ne fais rien, je ne vois pas tous les tuners qui sont trop lent à monter. Aussi j'ai retardé le lancement du backend de quelques secondes pour qu'il démarre à tous les coups correctement. Il n'y a rien de spécial à faire pour le frontend qui se connecte au backend quand il est dispo.

Hors ligne

Réponse rapide

Veuillez composer votre message et l'envoyer
Si vous êtes un être humain ne changez pas le contenu de ces deux champs.

Pied de page des forums

Propulsé par FluxBB

Webmasteur SnouF

Hébergé par Tuxfamily

Valid XHTML 1.0 Strict