#1 14/11/2009 17:38:52

SnouF
Webmasteur, développeurDéveloppeur de scripts pour mythtv (tel que des grabbeurs pour MythNetVision). S'occupe également du dépôt deb des scripts mythtv-fr et propose un dépôt mythtv-fixes pour debian (stable, testing et unstable).
Inscription : 02/11/2007
Messages : 4 565
Site Web Mythbox

[Résolu] Ma TV crois recevoir le son via DVI/HDMI alors que non

Bonjour à tous,

je viens de mettre à jours ma mythbox, et la TV ne veux pas sortir le son analogique que je lui transmet. Mais si je branche un casque à la place de la TV ça marche.

Mon installation :
  * Mon pc est branché à ma TV :
    - Pour le son : via une prise jack sur la carte son intégrée en analogique
    - Pour l'image : via un adapteur dvi-hdmi sur la TV (dvi coté PC, hdmi coté TV) carte graphique nvidia avec driver proprio.

J'ai l'impression que le pc envoi via l'hdmi à la tv comme quoi le son passe par l'hdmi hors ce n'est pas le cas. La tv "écoute" sur l'hdmi alors qu'elle devrait "écouter" sur l'analogique et rien ne sort des haut parleur.

Si cette piste et la bonne, quelqu'un sais comment "dire à la tv" qu'il faut prendre le son via l'analogique et pas l'hdmi ?

Si la piste est maivaise, une idée pour résoudre la problème ?

[edit] modif du titre

Dernière modification par SnouF (15/11/2009 18:09:43)

Hors ligne

#2 14/11/2009 17:53:47

gilles74
Administrateur, expert MythTVExpert en configuration du DVB-SAT., développeurMembre de l'équipe de traduction, s'occupe de l'adaptation francophone de accuweather.
Inscription : 20/02/2008
Messages : 3 914
Mythbox

Re : [Résolu] Ma TV crois recevoir le son via DVI/HDMI alors que non

Il faut que tu regardes la notice du téléviseur. Sur le mien, j'ai le choix de recevoir du son analogique ou digital sur l'entrée HDMI.
Sinon il te faudra passer par un ampli extérieur ou un casque .......

Hors ligne

#3 14/11/2009 18:00:17

SnouF
Webmasteur, développeurDéveloppeur de scripts pour mythtv (tel que des grabbeurs pour MythNetVision). S'occupe également du dépôt deb des scripts mythtv-fr et propose un dépôt mythtv-fixes pour debian (stable, testing et unstable).
Inscription : 02/11/2007
Messages : 4 565
Site Web Mythbox

Re : [Résolu] Ma TV crois recevoir le son via DVI/HDMI alors que non

Ce qui m'échappe c'est que avant les grosses mise à jours ça fonctionnait ! et je n'ai pas toucher au branchement sad.

Hors ligne

#4 14/11/2009 20:25:34

dalgwen
Expert MythTV
Inscription : 16/12/2007
Messages : 617
Mythbox

Re : [Résolu] Ma TV crois recevoir le son via DVI/HDMI alors que non

Question bête : pourquoi n'utilises tu pas le son via HDMI ? Il y aurait moins de perte.

Sinon, tu n'as pas l'air d'être le seul à avoir ce problème.
J'espère que tu es bon en anglais : http://forums.nvidia.com/index.php?showtopic=99932 (utilisateur windows)
On dirait qu'il faut modifier l'EDID que transmet ton téléviseur pour faire croire à ta carte graphique que celui ci ne supporte pas l'audio par HDMI.
Je sais que c'est possible sous linux avec les drivers proprio nvidia (on passe en paramètre un fichier pour spoofer l'edid dans le xorg.conf, fichier que l'on a préalablement récupérer via un dump fait par un utilitaire dont j'ai oublié le nom et modifier à la main) mais je n'ai jamais essayé..

Dernière modification par dalgwen (14/11/2009 20:27:38)


Disclaimer : J'ai migré sur tvheadend mais je passe encore ici de temps en temps (bouuhhh le traître)

Hors ligne

#5 14/11/2009 21:49:42

gilles74
Administrateur, expert MythTVExpert en configuration du DVB-SAT., développeurMembre de l'équipe de traduction, s'occupe de l'adaptation francophone de accuweather.
Inscription : 20/02/2008
Messages : 3 914
Mythbox

Re : [Résolu] Ma TV crois recevoir le son via DVI/HDMI alors que non

dalgwen a écrit :

Question bête : pourquoi n'utilises tu pas le son via HDMI ? Il y aurait moins de perte.

parce sa sortie est une DVI Digital Vidéo Interface qui ne véhicule pas le son au contraire du HDMI qui véhicule le même signal vidéo et l'audio analogique ou digital

dalgwen a écrit :

On dirait qu'il faut modifier l'EDID que transmet ton téléviseur pour faire croire à ta carte graphique que celui ci ne supporte pas l'audio par HDMI..

Ca s'est une vraie bonne piste

Regarde les options du driver Nvidia. J'ai déjà utilisé l'option "ConnectedMonitor" pour utiliser la sortie DVI ou "NoDCC" pour ne pas utiliser l'edid

Hors ligne

#6 15/11/2009 11:32:13

dalgwen
Expert MythTV
Inscription : 16/12/2007
Messages : 617
Mythbox

Re : [Résolu] Ma TV crois recevoir le son via DVI/HDMI alors que non

gilles74 a écrit :

parce sa sortie est une DVI Digital Vidéo Interface qui ne véhicule pas le son au contraire du HDMI qui véhicule le même signal vidéo et l'audio analogique ou digital

Arf.... Merci, je suis aveugle. Je suis le premier a régulièrement pester contre ceux qui lisent à moitié les messages et c'est exactement ce qui vient de m'arriver wink


Disclaimer : J'ai migré sur tvheadend mais je passe encore ici de temps en temps (bouuhhh le traître)

Hors ligne

#7 15/11/2009 17:35:29

SnouF
Webmasteur, développeurDéveloppeur de scripts pour mythtv (tel que des grabbeurs pour MythNetVision). S'occupe également du dépôt deb des scripts mythtv-fr et propose un dépôt mythtv-fixes pour debian (stable, testing et unstable).
Inscription : 02/11/2007
Messages : 4 565
Site Web Mythbox

Re : [Résolu] Ma TV crois recevoir le son via DVI/HDMI alors que non

J'ai fait différent essais mais ... je ne comprend pas bien la doc nvidia (en tas d'abréviation dont j'ignore le sens).

Option "NoDDC" "boolean"
Synonym for "IgnoreEDID". This option is deprecated, and no longer affects behavior of the X driver. See the "UseEDID" option for details.

Je suis donc aller voir du coté de "UseEDID"

Option "UseEDID" "FALSE"

Réactive le son mais l'écran passe en résolution très basse (<640x480) sad
J'ai fais d'autres test un peu à l'aveuglette mais rien de concluant.

Est-ce que quelqu'un comprend cette doc ? si oui peut-il me guider car je patauge ?

Sinon je pense que je vais opter pour l'option "dalgwen" en changeant de carte graphique.

Hors ligne

#8 15/11/2009 20:03:24

dalgwen
Expert MythTV
Inscription : 16/12/2007
Messages : 617
Mythbox

Re : [Résolu] Ma TV crois recevoir le son via DVI/HDMI alors que non

Donc il s'agit bien d'un problème d'EDID et de driver.
Le driver NVIDIA maintenant est capable de voir que la télévision est capable de recevoir du son par HDMI et désactive du coup le son analogique.

Tu as deux possibilités :
1- désactiver l'edid comme tu l'as fait dans ton test, dans ce cas il faudra que tu fournisses une modeline la plus complète possible pour avoir la bonne résolution à la main.
2- spoofer l'edid comme cela est fait sur windows dans le post que j'ai copié collé. Comme ça les infos de résolution sont toujours là, il faut juste trouver le bon champ pour l'audio.

Si tu te sens l'âme aventureuse et que tu tentes la solution deux, on peut essayer un truc :
- depuis le panneau de conf nvidia fait "acquire EDID"
- edite avec un éditeur hexa/binaire le fichier résultant et modifie le bit responsable de l'audio en le passant de 1 à 0. Ce bit est probablement le 7ème du 4ème octet, d'après wikipedia :

Byte sequence
00: Extension tag (which kind of extension block this is); 02h for CEA EDID
01: Revision number (Version number); 03h for Version 3
02: Byte number "d" within this block where the 18-byte DTDs begin. If no non-DTD data is present
    in this extension block, the value should be set to 04h (the byte after next). If set to 00h,
    there are no DTDs present in this block and no non-DTD data.
03: Number of DTDs present, other Version 2+ information
     bit 7: 1 if display supports underscan, 0 if not
     bit 6: 1 if display supports basic audio, 0 if not
     bit 5: 1 if display supports YCbCr 4:4:4, 0 if not
     bit 4: 1 if display supports YCbCr 4:2:2, 0 if not
     bit 3..0: total number of native formats in the DTDs included in this block

- Configurer Xorg pour prendre ton fichier EDID modifié, dans la section device

Option "CustomEDID" "DFP-0:/etc/X11/chemin-vers-ton-EDID"

Je n'ai pas trouvé de how to pour linux, donc je ne peux que me baser sur ma maigre compréhension de ce que je lis à droite à gauche...
Ce qui veut dire : aucune garantie, à tes risques et périls ;-)

Dernière modification par dalgwen (15/11/2009 20:05:09)


Disclaimer : J'ai migré sur tvheadend mais je passe encore ici de temps en temps (bouuhhh le traître)

Hors ligne

#9 16/11/2009 12:00:56

dalgwen
Expert MythTV
Inscription : 16/12/2007
Messages : 617
Mythbox

Re : [Résolu] Ma TV crois recevoir le son via DVI/HDMI alors que non

Ajout :
Tu peux trouver des logiciels qui éditent les données d'un fichier edid et le présente sous une forme plus user friendly.
Une recherche google sur "edid editor" t'en dira plus.
Ce sera plus facile pour identifier les infos à modifier.

(bon, malheureusement beaucoup sont sous windows, mais une fois que le fichier edid est modifié tu es tranquille ...)


Disclaimer : J'ai migré sur tvheadend mais je passe encore ici de temps en temps (bouuhhh le traître)

Hors ligne

#10 16/11/2009 19:02:16

cortex (frère de SnouF)
Invité

Re : [Résolu] Ma TV crois recevoir le son via DVI/HDMI alors que non

La solution de dalgwen ne marche pas même après avoir changé le checksum

Mais grace à ça j'ai trouvé la solution
http://blog.mymediasystem.net/my-media- … ps-lcd-tv/

et ça marche !

[edit SnouF] L'othographe c'est dans les gènes big_smile

#11 16/11/2009 21:03:48

dalgwen
Expert MythTV
Inscription : 16/12/2007
Messages : 617
Mythbox

Re : [Résolu] Ma TV crois recevoir le son via DVI/HDMI alors que non

Ah ouais, je m'étais planté sur les bits à modifier.
Content de voir que j'étais "pas trop" loin quand même wink

Dernière modification par dalgwen (16/11/2009 21:04:18)


Disclaimer : J'ai migré sur tvheadend mais je passe encore ici de temps en temps (bouuhhh le traître)

Hors ligne

#12 16/11/2009 22:02:43

SnouF
Webmasteur, développeurDéveloppeur de scripts pour mythtv (tel que des grabbeurs pour MythNetVision). S'occupe également du dépôt deb des scripts mythtv-fr et propose un dépôt mythtv-fixes pour debian (stable, testing et unstable).
Inscription : 02/11/2007
Messages : 4 565
Site Web Mythbox

Re : [Résolu] Ma TV crois recevoir le son via DVI/HDMI alors que non

Comme vous l'avez remarqué j'ai passer le "bébé" (problème de son) au frèro ! (car moi les éditeurs hexa/binaire et autre bit je ne connais que le nom smile )

Dernière modification par SnouF (19/11/2009 12:53:57)

Hors ligne

#13 31/12/2009 20:20:57

piratebab
Co-fondateur de MythTV-fr
Lieu : Sud Ouest
Inscription : 30/11/2007
Messages : 4 063
Mythbox

Re : [Résolu] Ma TV crois recevoir le son via DVI/HDMI alors que non

Je viens d'installer la même config, et tout c'est passé sans problème, pas de config lourde à faire.
J'ai vu quelque part lors d'un passage sous gnome, qu'il y avait la possibilité de configurer la sortie son via la carte graphique ou en direct.
sous xfce je n'ai pas trové le même réglage, mais tout à fonctionné du 1er coup.


Mythuser depuis 2005

Hors ligne

Réponse rapide

Veuillez composer votre message et l'envoyer
Si vous êtes un être humain ne changez pas le contenu de ces deux champs.

Pied de page des forums

Propulsé par FluxBB

Webmasteur SnouF

Hébergé par Tuxfamily

Valid XHTML 1.0 Strict