#1 25/04/2011 20:40:59

Eric59
Membre
Inscription : 26/11/2010
Messages : 111
Mythbox

[Résolu] sortie son par défaut => HDMI

Ma mythbuntu fonctionne maintenant très bien et j'en profite vraiment pleinement. Je souhaiterai profiter d'un PC connecté à la TV pour apporter d'autres fonctions qu'un frontend (du genre navigation sur youtube, une console de jeu,... ).

Dans ma config MYTHTV, la sortie audio est réglé sur ALSA:plughw:1,7. J'ai donc le son via hdmi depuis myth- frontend.

Par contre, dès que je lance firefox ou tout autre application, mon pc reste muet. La sortie HDMI n'est donc pas la sortie de XFCE par défaut.

Quelqu'un connait-il les paramètres pour rediriger le son vers la sortie HDMI par défaut ? Je rappelle que je suis sur mythbuntu et donc je n'ai pas de pulseaudio qui tourne.

Dernière modification par Eric59 (25/04/2011 20:43:00)

Hors ligne

#2 26/04/2011 10:01:12

piratebab
Co-fondateur de MythTV-fr
Lieu : Sud Ouest
Inscription : 30/11/2007
Messages : 4 062
Mythbox

Re : [Résolu] sortie son par défaut => HDMI

Il faut que tu ailles dans le fichier de config d'alsa.
Je ne sais pas comment c'est fait sur une mythbuntu,
Ce que tu peux faire:
- désactiver dans le BIOS la carte son si elle est intégrée
- supprimer le driver de la carte son afin de ne conserver que la sortie HDMI (/etc/modprobe.d/alsa.conf)
- modifier /usr/share/alsa/alsa.conf ou ~/.asoundrc afin de mettre la sortie HDMI comme sortie par défaut

tu peux regarder http://alsa.opensrc.org/MultipleCards


Mythuser depuis 2005

Hors ligne

#3 26/04/2011 13:06:43

SnouF
Webmasteur, développeurDéveloppeur de scripts pour mythtv (tel que des grabbeurs pour MythNetVision). S'occupe également du dépôt deb des scripts mythtv-fr et propose un dépôt mythtv-fixes pour debian (stable, testing et unstable).
Inscription : 02/11/2007
Messages : 4 563
Site Web Mythbox

Re : [Résolu] sortie son par défaut => HDMI

La conf via le fichier de configuration alsa devrait fonctionner mais plutôt que d'éditera le fichier à la main essai alsamixer

Sinon ,les sons de XCFE4 "sortent " par ou ?

Dernière modification par SnouF (26/04/2011 13:11:56)

Hors ligne

#4 26/04/2011 18:14:17

Ookaze
Expert MythTVMembre de l'équipe de traduction et traducteur de la documentation.
Inscription : 15/01/2008
Messages : 884
Mythbox

Re : [Résolu] sortie son par défaut => HDMI

Je ne vois pas trop comment cela peut fonctionner sans un pulseaudio ou autre serveur de son entre les deux.
Il suffit qu'une application s'approprie le périphérique de son, au hasard un frontal MythTV, pour que les autres applications soient bloquées au niveau du son (et parfois bloquées tout court).

Hors ligne

#5 26/04/2011 21:27:09

piratebab
Co-fondateur de MythTV-fr
Lieu : Sud Ouest
Inscription : 30/11/2007
Messages : 4 062
Mythbox

Re : [Résolu] sortie son par défaut => HDMI

Il me semble que XFCE utilise esound.
Le son sous linux fonctionnait avant l'arrivée de pulseaudio !


Mythuser depuis 2005

Hors ligne

#6 27/04/2011 13:24:24

SnouF
Webmasteur, développeurDéveloppeur de scripts pour mythtv (tel que des grabbeurs pour MythNetVision). S'occupe également du dépôt deb des scripts mythtv-fr et propose un dépôt mythtv-fixes pour debian (stable, testing et unstable).
Inscription : 02/11/2007
Messages : 4 563
Site Web Mythbox

Re : [Résolu] sortie son par défaut => HDMI

Eric59, Ookaze me fait pensé à un truc smile chez moi (MythTV 0.23.1) Au lancement de mythfrontend le son des autre application est coupé (via pluseaudio je crois)

Donc durant tes tests ne démarre pas Mythfrontend smile

Hors ligne

#7 27/04/2011 18:26:07

piratebab
Co-fondateur de MythTV-fr
Lieu : Sud Ouest
Inscription : 30/11/2007
Messages : 4 062
Mythbox

Re : [Résolu] sortie son par défaut => HDMI

Sur ma mythbox, j'ai désactivé la carte son intégrée via le BIOs.
Comme ça, plus de conflit et de prise de tête.


Mythuser depuis 2005

Hors ligne

#8 28/04/2011 12:55:37

Ookaze
Expert MythTVMembre de l'équipe de traduction et traducteur de la documentation.
Inscription : 15/01/2008
Messages : 884
Mythbox

Re : [Résolu] sortie son par défaut => HDMI

Je ne pourrais pas régler ce problème mais juste fournir des pistes.
Pour régler le problème, il faut la version de distribution, du noyau Linux, éventuellement de alsa-lib, et le gestionnaire de son éventuel par-dessus.

tl;dr : il ne devrait pas y avoir de nom cryptique configuré pour le son si la version de MythTV est récente (à partir de 0.24 ou 0.23 je ne sais plus) ainsi que l'OS. Si l'on a besoin de créer des fichiers de configuration pour ALSA, c'est aussi clairement que l'on est dans une mauvaise configuration : cela ne doit plus arriver de nos jours.

Plus long :
Avant, le son était compliqué à gérer parce que tout avait des noms cryptiques comme celui du message original.
Les accès concurrents fonctionnaient plus ou moins selon que les applis étaient bien codées ou pas, quant aux configurations comme la mienne avec plusieurs sessions utilisateur différentes ouvertes en même temps sur la même machine, cela ne fonctionnait pas : seule une personne avait le son en même temps.

Depuis maintenant presque 2 ans, un gros travail a été fait au niveau de ALSA pour que tout fonctionne tout seul au niveau configuration. Au moment où ce travail était en passe d'être terminé, tous les daemons gestionnaires de son étaient obsolètes ou avaient des problèmes bien identifiés, mais personne ne s'était mis à la tâche pour améliorer tout ça.
L'amélioration d'ALSA a commencé avec le souhait de Linus de faire un noyau avec un OS où tout fonctionne tout seul lorsque l'on branche, et devait aussi gérer des environnements de plus en plus dynamiques (problématiques de (dé)branchements à chaud, PATA vers SATA, série ou parallèle vers USB, les fameux branchements à des vidéoprojecteurs, ...). Donc les deux mots d'ordre étaient autoconfiguration et gestion dynamique du matériel. Udev et cie viennent de là.
Le son n'est pas le seul touché, mais tout l'OS : les modifications de XOrg viennent aussi de là. Tout comme le fichier de configuration pour ALSA, un fichier xorg.conf ou autres modeline ne devraient plus exister normalement, seulement des petits fichiers de configuration pour des cas particuliers. Et on voit bien le temps que ça prend pour que les gens et surtout les distributions n'utilisent plus de xorg.conf.

Comme la gestion des périphériques sonores est maintenant complètement dynamique jusque dans ALSA, il est possible de rajouter ou d'enlever des périphériques sonores à chaud. Et dans ce cas, tous les gestionnaires de son précédents sont dans les choux, en plus d'être obsolètes, et à fortiori si on enlève un périphérique. Un autre gros travail a été effectué afin de proposer un gestionnaire de son nouvelle génération gérant toutes ces problématiques, avec les mêmes mots d'ordre : autoconfiguration et gestion dynamique.
Ça c'est pulseaudio.
PulseAudio va faire le plus difficile du boulot, comme par exemple migrer le son vers un autre périphérique si on enlève le principal configuré. Ou encore fournir des noms compréhensibles comme "analogique 5.1" ou "HDMI" ou "écouteurs"...
Malheureusement, cela demande quand même un effort aux développeurs pour coder correctement leurs applications pour utiliser les API pulseaudio. Et déjà cela n'est pas évident, d'une part parce que certaines distributions comme Ubuntu font n'importe quoi en patchant pulseaudio, d'autre part parce qu'il faut coder différemment son accès à l'audio, en prenant en compte l'aspect dynamique.

Certaines distrib préfèrent donc ne pas changer leurs habitudes et éviter les problèmes en détruisant PA, et d'autres projets se focalisent sur ALSA, mais sans prendre en compte l'aspect dynamique. Bref, ils restent dans le n'importe quoi d'avant, et ne sont pas du tout flexibles. Les développeurs de MythTV ont fait un effort, mais ce n'est pas encore suffisant, et donc le support de PulseAudio est toujours buggé.

Donc on peut plaquer son MythTV sur ALSA si l'on a une mythbox et que c'est donc la seule appli qui accède au périphérique de son.
C'est développé comme ça pour les raisons que j'ai expliqué plus haut : en gros c'est plus simple. Mais on voit bien l'inadéquation de cette méthode en cas d'accès concurrent comme l'indique le problème de l'utilisateur plus haut.

Dernière modification par Ookaze (28/04/2011 12:59:56)

Hors ligne

#9 28/04/2011 13:15:56

SnouF
Webmasteur, développeurDéveloppeur de scripts pour mythtv (tel que des grabbeurs pour MythNetVision). S'occupe également du dépôt deb des scripts mythtv-fr et propose un dépôt mythtv-fixes pour debian (stable, testing et unstable).
Inscription : 02/11/2007
Messages : 4 563
Site Web Mythbox

Re : [Résolu] sortie son par défaut => HDMI

Merci Ookaze smile j'ai appris un tas de chose smile

Mais laissez Eric59 répondre smile il va repartir en courant quand il va s'apercevoir qu'il y a 8 posts pour une question qui n'est pas si compliqué que ça.

Hors ligne

#10 28/04/2011 13:24:03

piratebab
Co-fondateur de MythTV-fr
Lieu : Sud Ouest
Inscription : 30/11/2007
Messages : 4 062
Mythbox

Re : [Résolu] sortie son par défaut => HDMI

Merci professeur Ookaze smile Toujours aussi clair et didactique!
Je ne partage pas ton avis sur pulseaudio, étant toujours dans une logique d'optimisation d'un matériel donné pour un usage donné (je ne tolère pas par ex de jeter un vieux PC à base de Pentium IV alors qu'il fait encore un très bon serveur sous debian ...).
Pulseaudio est pour moi une couche supplémentaire entre ALSA et les applications. Cela rajoute des ressources consommées, et de la latence. Sauf cas particulier (multicession comme toi, streaming via un réseau, ...) PA est inutile, voire néfaste.
Donc si on peux s'en passer, on s'en passe (au prix d'un peu de réflexion et de configuration manuelle).


Mythuser depuis 2005

Hors ligne

#11 28/04/2011 20:20:43

FabriceMG
Développeur cinépassion.plcinépassion.pl sur le wiki.
Inscription : 03/11/2009
Messages : 193

Re : [Résolu] sortie son par défaut => HDMI

Hors ligne

#12 28/04/2011 20:58:59

Eric59
Membre
Inscription : 26/11/2010
Messages : 111
Mythbox

Re : [Résolu] sortie son par défaut => HDMI

piratebab a écrit :

Sur ma mythbox, j'ai désactivé la carte son intégrée via le BIOs.
Comme ça, plus de conflit et de prise de tête.

bon, j'ai commencé par là.
Résultat : plus de son du tout. J'ai réactivé la carte intégrée (via le bios) et le son est revenu pour Mythtv (via ma nvidia en hdmi), ouf.

Dernière modification par Eric59 (28/04/2011 21:05:27)

Hors ligne

#13 28/04/2011 21:02:16

Eric59
Membre
Inscription : 26/11/2010
Messages : 111
Mythbox

Re : [Résolu] sortie son par défaut => HDMI

un aplay -l pourrait peut-être nous éclairer :

Linux Mythtv 2.6.35-28-generic #50-Ubuntu SMP Fri Mar 18 18:42:20 UTC 2011 x86_64 GNU/Linux
Ubuntu 10.10

Welcome to Ubuntu!
 * Documentation:  https://help.ubuntu.com/

New release 'natty' available.
Run 'do-release-upgrade' to upgrade to it.

Last login: Thu Apr 28 19:38:37 2011
eric@Mythtv:~$ aplay -l
**** Liste des PLAYBACK périphériques ****
carte  0: Intel [HDA Intel], périphérique 0 : ALC888 Analog [ALC888 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0
carte  0: Intel [HDA Intel], périphérique 1 : ALC888 Digital [ALC888 Digital]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0
carte  1: NVidia [HDA NVidia], périphérique 3 : NVIDIA HDMI [NVIDIA HDMI]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0
carte  1: NVidia [HDA NVidia], périphérique 7 : NVIDIA HDMI [NVIDIA HDMI]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0
carte  1: NVidia [HDA NVidia], périphérique 8 : NVIDIA HDMI [NVIDIA HDMI]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0
carte  1: NVidia [HDA NVidia], périphérique 9 : NVIDIA HDMI [NVIDIA HDMI]
  Sous-périphériques: 1/1
  Sous-périphérique: #0: subdevice #0

Impressionnant le nombre de périphériques NVIDIA HDMI, tout ça pour une seule sortie !!

Hors ligne

#14 28/04/2011 21:03:34

Eric59
Membre
Inscription : 26/11/2010
Messages : 111
Mythbox

Re : [Résolu] sortie son par défaut => HDMI

au passage, vous noterez :
New release 'natty' available.. J'ai bien envie de tester pour voir.

Hors ligne

#15 09/08/2011 18:28:04

Eric59
Membre
Inscription : 26/11/2010
Messages : 111
Mythbox

Re : [Résolu] sortie son par défaut => HDMI

Problème résolu aujourd'hui en créant le fichier .asoundrc à la racine du répertoire user de mythfrontend :

eric@Mythtv:~$ more .asoundrc
pcm.dmixer {
type dmix
ipc_key 1024
ipc_key_add_uid false
ipc_perm 0660
slave {
pcm "hw:1,7"
rate 48000
channels 2
period_time 0
period_size 1024
buffer_time 0
buffer_size 4096
}
}

pcm.!default {
type plug
slave.pcm "dmixer"
}

defaults.pcm.device 7

Hors ligne

Réponse rapide

Veuillez composer votre message et l'envoyer
Si vous êtes un être humain ne changez pas le contenu de ces deux champs.

Pied de page des forums

Propulsé par FluxBB

Webmasteur SnouF

Hébergé par Tuxfamily

Valid XHTML 1.0 Strict