#1 01/11/2012 16:43:23

lhebui
Membre
Lieu : Saint Martin des Bois
Inscription : 18/03/2008
Messages : 665
Mythbox

sasc-ng et noyau 3.5

Bonjour à tous,

Cela fait longtemps que je n'ai pas mis les pieds sur ce site mais j'ai un petit peu de temps maintenant ...

Je reviens sur cette envie d'enregistrer une émission cryptée d'hotbird.

Donc besoin de sasc-ng. Je suis allé sur le site de Dollot et il préconise de patcher le noyau quand la version est supérieure à 2.6.38 : http://dolot.kipdola.com/wiki/Install_SASC-NG#Linux_3.x

Alors mes questions sont les suivantes :

- Je fais une install complète en 12.10 ubuntu et le noyau est en 3.5. Dois-je toujours patcher le noyau ?
- A chaque mise à jour du noyau, dois-je patcher le nouveau noyau ?
- En 2 ans, la procédure a-t'elle évoluée pour pouvoir visionner une tv cryptée ?

Vous souhaitant une bonne journée.


RPI3+ en mythtv et TVHEADEND (en construction pour les 2 ...)

Hors ligne

#2 02/11/2012 14:14:56

Ookaze
Expert MythTVMembre de l'équipe de traduction et traducteur de la documentation.
Inscription : 15/01/2008
Messages : 884
Mythbox

Re : sasc-ng et noyau 3.5

Quand on te parle de patcher le noyau, le premier réflexe c'est de savoir si tu maîtrises parfaitement :
- le développement (compilation et cie), la construction d'un noyau Linux, et la façon spécifique de créer un noyau Linux;
- le système de packaging de ta distribution;
- le processus de démarrage d'une machine sous Linux;

Sinon il est fortement déconseillé de se lancer là-dedans. Ce ne sera que frustrations et déconvenues à l'arrivée.
Il faut voir que ce wiki te parle des noyaux version 3.0, or on est en 3.6 déjà, avec un paquet de modifs de partout, je ne parierai pas sur le fonctionnement de ce patch tel quel.

Normalement, un module externe bien fait ne patche surtout pas le kernel, il utilise juste les sources de celui-ci, comme le font par exemple VirtualBox ou RTSP.
Sur une distribution, il faut quelqu'un qui maîtrise tout ce dont j'ai parlé plus haut, qui le mette en place, qui fournisse le package et qui le maintienne. Une distribution c'est fait pour ça.
Mettre des outils construits soi-même sans gestion de package sur une distribution, c'est la voie ouverte au désastre, c'est complètement contre-productif.

Bon courage quand même.

Hors ligne

#3 02/11/2012 14:54:00

lhebui
Membre
Lieu : Saint Martin des Bois
Inscription : 18/03/2008
Messages : 665
Mythbox

Re : sasc-ng et noyau 3.5

Je vais suivre tes indications. Je vais utiliser mon pc pour enregistrer de la tnt terrestre car mythtv est vraiment très convivial et garder l'openbox F3 (beaucoup moins convivial) pour enregistrer le satellite.

Bonne journée.


RPI3+ en mythtv et TVHEADEND (en construction pour les 2 ...)

Hors ligne

#4 02/11/2012 20:12:16

piratebab
Co-fondateur de MythTV-fr
Lieu : Sud Ouest
Inscription : 30/11/2007
Messages : 4 062
Mythbox

Re : sasc-ng et noyau 3.5

Tu peux aussi te faire une machine de test à partir de piéces de récup pour te faire la main sur la compil d'un kernel linux.


Mythuser depuis 2005

Hors ligne

#5 02/11/2012 21:28:40

gilles74
Administrateur, expert MythTVExpert en configuration du DVB-SAT., développeurMembre de l'équipe de traduction, s'occupe de l'adaptation francophone de accuweather.
Inscription : 20/02/2008
Messages : 3 914
Mythbox

Re : sasc-ng et noyau 3.5

lhebui a écrit :

- Je fais une install complète en 12.10 ubuntu et le noyau est en 3.5. Dois-je toujours patcher le noyau ?
- A chaque mise à jour du noyau, dois-je patcher le nouveau noyau ?
- En 2 ans, la procédure a-t'elle évoluée pour pouvoir visionner une tv cryptée ?

Aux 2 premières questions, oui il faut patcher le noyau et sasc à chaque mise à jour du noyau

Mais pour le noyau, ce n'est pas une compilation au sens strict du terme: on ne touche pas au noyau, il n'y a pas besoin de re-compiler le noyau, il faut juste remplacer un fichier par un autre dans V4L. Ensuite il faut compiler sasc à chaque mise à jour du noyau et comme le conseille, il faut un minimum de base surtout pour compiler sous UBUNTU.

Sous ARCHLINUX il existe des paquets à la fois pour "patcher" le noyau et pour compiler sasc et c'est vrai que c'est la voie à privilégier pour éviter les ennuis.Mais ce n'est pas disponible sous toutes les distributions.

Sous Ubuntu, je te conseille de tester dvbuntu qui fournit tout ce qui faut pour installer sasc-ng

Hors ligne

#6 14/07/2013 18:36:05

lhebui
Membre
Lieu : Saint Martin des Bois
Inscription : 18/03/2008
Messages : 665
Mythbox

Re : sasc-ng et noyau 3.5

Bonsoir,

Je remets au devant ce post après avoir parcouru le site mythtv.fr et glaner quelques infos intéressantes ...

En effet, il existe une nouvelle version de sasc qui fonctionne avec des noyaux > 3.x. Puis, j'ai lu aussi qu'il existe un logiciel DVBuntu qui permet de configurer très rapidement son système de tuner DVB-S + lecteur de carte d'abonnement.

Est-ce aussi simple d'utiliser DVBuntu ? Je branche le tuner et le lecteur de carte chacun sur leur port usb et je me laisse porter par le logiciel ?

J'ai un p'tit doute là-dessus ...  Par contre, si c'est effectivement le cas ... je me lance dans la config.

N.B. : J'ai l'impression qu'il ne configure pas newcs ...


RPI3+ en mythtv et TVHEADEND (en construction pour les 2 ...)

Hors ligne

#7 15/07/2013 08:49:52

gilles74
Administrateur, expert MythTVExpert en configuration du DVB-SAT., développeurMembre de l'équipe de traduction, s'occupe de l'adaptation francophone de accuweather.
Inscription : 20/02/2008
Messages : 3 914
Mythbox

Re : sasc-ng et noyau 3.5

il existe bien une version de sasc qui fonctionne avec les noyaux (FabriceMG a donné le lien d'un dépot optimisé,voir cette discussion ).

Dans tous les cas, il ne faut pas dépasser la version 570, au delà c'est instable ou faire comme dolot, patcher sasc.

Tu peux essayer DVBbuntu mais je ne sais pas s'il est à jour par rapport au dernière modif du noyau. Cela dit je ne sais pas si ubuntu a suivi les recommandations du noyau qui modifiait l'emplacement des fichiers pour le dvb.

Mais de toute façon, tu as bien compris, il n'intégre pas news, ni oscam mais un logiciel qu'il utilise sur le sol nord-américain.

Je ne me suis pas intéressé à ce logiciel car sous archlinux, il est très facile d'installer sasc, le patch du noyau  et oscam avec des paquets.

Hors ligne

Réponse rapide

Veuillez composer votre message et l'envoyer
Si vous êtes un être humain ne changez pas le contenu de ces deux champs.

Pied de page des forums

Propulsé par FluxBB

Webmasteur SnouF

Hébergé par Tuxfamily

Valid XHTML 1.0 Strict